Add Folders on Networked MyBook to Favourites

WD Live Hub Latest Firmware
2TB My Book Latest Firmware also on my network…

I brows to a folder on my MB that I’d like to add to Favourites, and hit Options, but there is no “Add to Favourites”

What am I missing, please?

You’re not using Media Library.

Media Library is on.

I’ve selected “Add To Media Library” twice now… the 2nd time it said “Already added, chose another folder” but still no “Add To Favourites” option.


…and you have the Content Source set to Media Library?

Remind me where I check that???

*Edit… nothing to see here  ;-)  *


Your last post implied that you’d already found it?

Content Source is selected via the Red Button.

Yes… media source is “Library”

Still no joy. Cannot add those folders to Favourites.


Or is there no help to be had on this issue?  

Ahh but is the folder in “My Media Library” ?

Because if its not and you are looking at in in Network shares you will not be able to add it to Favourites or add content info etc…

As I posted earlier in the thread, I have added it… Why it’s not working is beyond me…

So and excuse me here…

You are sat with a view of your folders with after selecting “My Media Library” with the red button and it says that in the top right corner. And if there is a folder inside that, can you add that to favourites. ?

Now bear in mind  I myself have stuggled like **bleep** to get folders into my media library, it says its shared and its not there, or it says its already sharing a folder and this belongs to it blah blah…sometimes I have to put all the folders of that share into another folder inside just for it to show up, and then only after a Box reboot.

All these shares showed up in Network Shares, and on my PCs under network, but until I moved things one folder inwards it would not share it…bizarre

Oh so this is a known issue??? Yay…

I’ve been on the road but will have a closer look this weekend…

Is there a good step-by-step thing to follow anywhere??

Well its a known issue if its not added…

You seem to have acted as though you fixed it halfway through this thread ?

But baically if the folder is in “My Media Library” it ill work. if its not showing which you have never really answered 100%, then you just have to mess about with shares as I said. I am guessing you will not have rescan either, which is another option only added once in My Media Library.

I did not act like I fixed it half way through the thread… otherwise I wouldn’t still be looking for a solution.

Any step by step guide available?

All the steps are already given in this thread, and you have said you’ve done them.

Maybe you can post a YouTube video or something to show what you are doing?

A youtube video?

That’s even less helpful than the “Fiddle with the shares” suggestion…

Eh ?

Comments 6-7 have you saying…

*Edit… nothing to see here  ;-)  *


Post a screenshot of the folder you want in Favourites sat with “My Media Library” in the top right hand corner and then I would say you have a one in a million problem. Apart from that I think you are sharing it but its not showing up.

And to be honest your answers are not exaclty helping anyone, so good luck !

“Edit nothing to see here” was editing an irrelevant post…

“Crickets” was a comment on the lack of responses…

MY answers aren’t very helpful??? Good to know that I’m not alone in that then…

If there were helpful answers in this thread, this issue would be sorted by now.

Post a screenshot? And how do I do that? Post a screen shot of exactly what?