Access nil

Remote access I have never had !
Local access is becoming smaller by the minute.
One day I could go to finder, or Cmd+Shift+K which gives me a list of servers, click on wd my cloud and away we go.
Next day I had lost all access through finder.
I am on El Capitan, if that is the problem I can restore to former time and OS.
I can only access the dashboard by putting the ip address into browser
I can only access the drive by the WD software, which is an improvement as I couldn’t do that yesterday.
Both of these are local, I have never repeat NEVER been able to access it from anywhere else other than my house, my router.
trying the two options above asks me for name and password.
My name is already there, I have tried with capitals & without, I have tried the short name, I have tried my email address, they all fail.
I have stuck a paper clip in the reset for 40 seconds, gone thro the whole process of setting up again, same thing.
Would it be worth doing a reset and signing in with a different email address, user name and password ? There is a lot of stuff I have put on it, but nothing that cannot be put back on it, or possibly format the drive and start over, seems drastic measures.
Mapping the drive, sounds like a fun afternoon in store…
WD help have still not replied to my request of three days ago either !

I’m confused. If you are just setting up the My Cloud why are you giving it an email address? Generally to setup and access the my Cloud from the local network, using one’s web browser, they just need a user name that one created within the My Cloud and the password that one created within the My Cloud. The email address is only needed for two reasons; one is for remote access, the other is for alert email notifications if one enables that option within the Dashboard. To access the Dashboard one does not put in their email address in the name field unless, for what ever reason, they used an email address as the user name when setting up the My Cloud.

Typically when one does a 40 second reset it is supposed to reset the My Cloud administrator account and its username / password. If upon next Dashboard access you are prompted for a user name and password, use the name “Admin” and leave the password field blank.

Somewhere in the set up it asks for email address, I have tried to connect through finder with First name, first and second names, user name, and email, they are the four items I added at start up.
When I try to log in to wd2go my email address is already in the name field, if I try putting anything else in there it says “Enter a valid email address.
(Note: Use your MyCloud.com registered email address)”
and won’t let me in to the dashboard. Have to type in the ip address to access. When I go in that way the user name is admin and the password is blank. If I put Admin & blank into wd2go I get the above message…
Another 40second paper clip coming on I can feel it,
Thnx

Just done another 40seconder.
Went to the WD software on desktop and it logged me in to dashboard with Admin & blank
Went to wd2go logged me in with email and password. There’s an improvement !
Went to finder tried to log in - Nada, connection failed.
The thing is up and running now, it’s just so infuriating because I could log in thro finder much easier than going to wd2go & now I can’t.
Can log in on android tablet with my cloud software, will try remote access from My son in laws tonight,

Thnx

Have you looked at the thread on the ElCapitan problems?
Which version of ElCap are you running?

When you do the dashboard setup, it asks you to accept T&Cs, and then asks you to give an email address. You can skip this stage by pressing ‘cancel’ and it will continue with the setup.

@normski4ash, STOP trying to access your My Cloud through the WD2Go.com website UNTIL you figure your problems on the local network with trying to access the My Cloud. Get the My Cloud working properly on the local network FIRST before messing around with remote access through the WD2Go.com web portal.

Have you tried accessing the My Cloud Shares as mentioned above using smb:// or afp:// on your Mac’s?

If using El Capitan have you reviewed the huge El Capitan thread to see if anything in there is of use in your situation?

https://community.wd.com/t/support-os-x-el-capitan/96744

Have you tried mapping a Share to make access easier?

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=2686

IT WORKS ! finally I have access from outside home . thanks bennor you are a star. Thnx a million

What was the solution to fixing remote access?

Just another 40sec reset, didn’t do anything else. Let’s hope.

Hi Bennor,

Now up to my 12th 40sec reset…
WD have answered my cries for help, finally, just sent them some screen shots of the firmware version etc. Hoping for a rapid reply…
Since I proclaimed “it works” I have had to press the reset button twice a day. Reset this morning to get it working, (still no access from finder) got to work, it’s working from afar,

Ooops, sorry, to continue,
However by lunch time it had stopped again, infact my android came up with error 403 whatever that is…
Come home tonight, try to access from the software tells me the SSL certificate is invalid, tell it to continue and it lets me in.
Try to access the dashboard from wd2go tells me no devices available.
Access the dashboard from the IP address works fine.
Strongly suspect I have a duff budgie, Normski

You can’t access the dashboard remotely, only locally.

Have you read the user manual yet? [Edit: I take that back, since you say you’ve read it cover to cover. But if you misunderstand dashboard access…?]

Sorry, yes, I am going round and round in circles I’m completely lost !
If I go wd2go and try to access the drive, be it locally or from afar I gat that error message, " No devices available "
Trying to access from wdmycloud.local/ says " This site can’t be reached ".
If I enter the ip address I go to the dashboard, only way I can get to it ever !
The first week I could access from finder, now I can’t tells me connection failed.

@normski4ash, like I suggested previously focus on just your local network issue right now. Spending time accessing MyCloud.com/WD2Go.com is just wasting time at this point if you are having local network problems accessing the My Cloud.

Who is your broadband provider? If AT&T some people recently have problems with AT&T Uverse routers that require them to put a switch or hub in between the My Cloud and the AT&T router.
What firmware version; v3.x/v4.x or v2.x is your My Cloud using? (Firmwarev ersion is listed on the main home Dashboard page.)
Do you have a non Macintosh computer you can use to test with on your local network to see if that non Mac computer has trouble accessing the My Cloud?
If you can access the My Cloud Dashboard, have you configured the My Cloud for a Static IP Address (Dashboard > Settings > Network > Network Services > Network Mode) or have you configured the broadband router to issue (or reserve) the My Cloud a Static IP Address?

You have two separate issues. Local access and remote access. Address and fix the local access first, before tackling the remote access issues.

Hi M8,
Broadband provider is EE, or BT as they just bought them out, firmware is up to date, will dig out an old windoze lappy this weekend and try there.
Have now set static ip up for it and it now let’s me in at wdmc.local, however before this it told me how the usage was split up, so much music, so much movie etc, now there are no music or movie etc, just 2.6Tb free space. have included two screen shots, B4 & after. No biggy I suppose if it gets the thing working.
Off to work now will check remote access when there, Thnx, Normski

Absolutely no remote access today since setting static ip address, have just done a system report and sent to WD, see what they make of it,
Thnx, Normski

Do you have UPnP enabled on your router? If not, have you forwarded the relevant ports to the new(?) static IP? Assuming you assigned a different IP, that is…

Do you still have local access to it?

Trite as it might sound, have you tried turning cloud access off and on again…?

What does the cloud access status say? Is it reporting port forwarding or relay mode established?

I found that port forwarding only works for the lifetime of my router’s global IP address, which my ISP changes every time my router reboots. Which, at the moment, is every few days. In order to re-establish remote access after such an IP change, I had to toggle cloud access. this seemed to get the port forwarding link established again.

Relay mode seems to avoid this problem somehow, and continues to work regardless of my router’s global IP address.

I have local access on my imac, the one I used to set ip to static.
I didn’t assign a new ip address, should I have ? I’m a novice at the workings of a pc… Nowhere does it tell me to do that, or nowhere that I saw.
I have absolutely no access from any other pc or tablet.
Turned it on and off and done 40second resets until the buttons are worn out…
Port forwarding explanation left a lot to be desired, I think I did it, but uncertain, actually probably not. Again the instructions were vague, they seem to think that a new born baby understands the theory of relativity ! If you were a scientist or a doctor and I told you to get a Torx bit and remove the caliper from the OSF wheel, would you know what to do, or get a screwdriver and rewire an entire house, each to there own, because I don’t understand what they are talking about, doesn’t mean I shouldn’t have one, just like the doctor drives a car and the scientist has lights in his house. Some people need better instructions than what is given. Thnx Normski

Often times that is what Google or other Internet search engines are for.

Do an internet search for your router model + the words “port forwarding” and I’ll bet you get numerous hits that detail how to configure port forwarding within your router. Same goes for searching for your router model + assign static IP. The My Cloud User Manual (http://www.wdc.com/wdproducts/library/?id=439&type=25) gives general directions on how to configure the My Cloud for a static IP and to setup manual ports both of which are covered in Chapter 9.

Just gone to my router & port forwarding, I might as well go to the hospital and perform brain surgery with a Haynes manual…
It means nothing to me and I suspect it will make matters worse, why won’t the dam thing work straight out of the box as promised, I shouldn’t need a degree in techy to plug and play ! Let’s wait and see what my sys report to Wd comes back with, Thnx for your help, I think I am in way over my head and gonna end up throwing it in the bin…