A possible fix for the Initio Default Controller problem

I’ve tried to reach out to as many others affected by this as possible via Personal Messages. In most cases I can’t reply to the message threads, which limits my impact.


I was able to recover my HDD after it entered Initio limbo. I did all of the things that other people have mentioned: uninstalling the Initio driver, disabling the Initio device, fiddling with the cable, using more USB power, trying HP disk drive utilities, WD utilities, MSFT USB utilities, etc.


I tried reaching out to WD Support, but they have no tools to help when the firmware is wonky in this post-smart update firmware age. I actually contacted Initio to see if they could help, and they were very responsive, but there wasn’t much that they could do. I opened up my drive and encountered the mystery non-SATA connection internals.


I work at Microsoft, so it drives me nuts when I cannot get to the root of software issues. Fortunately, I worked my way through this one. To fix it, I had to use an older version of the firmware updater:



It seems that this older version of the firmware updater was smart enough to detect properly flashed WD drives and the “transition state” / “blank slate” ones. I really hope that this helps you. Let me know if it does, and my sympathies if it does not.




Thank you for taking the time to post this. Hope it helps other users.

I never thought the solution would be that simple!

I’ve been looking for ways to fix this for a few hours now, and my next step was to write a wrapper for InitioDevicePlugin.dll and try to send it the firmware that way. It really makes me feel bad about all the people who ran through similar problems over the past few yeart, though, seeing how drives in such a state are actually very much fixable, but newer versions of the firmware updater just won’t detect the Initio controller while it’s in recovery/default state.

I made an account here just to thank you, and I hope this post will end up rising on various search engines in the results for “Initio default controller” related queries.


I was updating Western digital My Passport Essential firmware and it said firmware upgrade faild and it was recognizing as Inito Default Controller.

I tried many ways, non was not working. This one worked very well!!


My Dear , This solution was very helpful, my drive started working again after i lost hope in it
Thank you for your help.

Brilliant and the fix I needed to get past that stupid Initio Controller Limbo after updating my firmware on a 1TB My Book Elite failed for no discernible reason. Thank you thank you thank you for your hard work and sharing it with us.

I made an account here just to thank you, and I hope this post will end up rising on various search engines in the results for “Initio default controller” related queries.

Thanks so much for posting this. I was attempting firmware update with the latest utility and ended up in Initio state. The older firmware updater and then re-doing the latest update worked great.

I installed the driver and it didn’t fix the problem but then I swapped the power cord to my external drive for another one and that seemed to fix it. Still not sure if it was driver or the power cord swapped but both together seemed to work for me. Thanks OP!!

You sir are a genius. Thank you so much for the simple solution of my “initio default controller” problem. 1.000 grats from germany!

Thank you, it works!!

Thank You, My Passport Essential is working again

I’ve installed the firmware updater but when I press rescan, this window comes up saying that it’s not a file released by Initio.

Then this window shows:

When I press update firmware and press accept on the next screen these windows come up:

Is there something wrong with what I did?

Hi Jamie, this is a crash in MSVC++ runtime, so I’m not sure what the problem is. From the error I can’t tell which version is affected, either. Since this is an outdated firmware update app, WD will never fix it. Some suggestions:

  1. Start the installer as admin
  2. Start the installer in compatibility mode
  3. Check if you have the MSVC++ runtime installed in your system, and update whatever versions that you have
  4. Install the latest version of MSVC++ (https://support.microsoft.com/en-us/kb/2977003)

It’s possible that the installer is starting to fail on recent versions of Windows (e.g. 10 or 10 Anniversary Update, etc.), but I doubt that.

Let us know if any of these suggestions help!

Hi Tim!

The solution you suggested going the firmware update way worked like a charm!

Thanks a lot indeed for sharing with us this trick.


Thank You Sir. Because you took time to post the solution I now have smile on me. I have been trying to fix the issue that HD is not being recognized in Device manager/ Disk manager for almost a day and tried many things and almost certain that HD has crashed and all my data (life’s photograph) are lost. Thank you again and I really appreciate your kindness.


Hi Tim,

Created an account just to thank you. I tried every other solution but yours saved my precious and saved me from a mini breakdown lol!


Did you find a solution to this? I am having the same issue.

Did you get this to work? I am getting the same error.

I"ve tried everything you suggested. Nothing worked. I also got the same announcement as Jamie_Smith. (nov. 2016).

How can I get my external drive to work again so I have acces to my foto’s on it??

It is not recognised on my computer…initio default controller. / initio Combo device Class.

Bought new cables…everything…please HELP.