3TB and 2TB My Book Essential Unmounting in Sleep Mode in Mountain Lion (OS 10.8)

Any help with the following issue is greatly appreciated… Ever since upgrading to Mountain Lion (10.8), I’ve been experiencing an issue of my WD Drives disconnecting/unmounting whenever my computer goes into sleep mode. I never had this issue using default drive and system settings in my previous OS installation – Lion (10.7.x). The drives are connected to my Macbook Pro 17in. (Mid 2010) via a USB hub. After each disconnect I have to launch Smartware to reconnect to each drive. Needless to say, this is a hassle. There appears to be an obvious incompatibility these drives have with Mountain Lion. I’ve tried modifying various drive and system settings to no avail. The firmware for each drive is updated to the latest version and I am using an up-to-date version of Smartware (v1.3.4.1). Coincidentally, a WD Drive of a different type that I’ve tested does not have the same issue.

I am having the exact same problem with my 2TB My Book Essential since upgrading to Mountain Lion.

It is definitely something wrong with the drive (or the drivers) as my other drives do not dismount once the Mac goes to sleep.  I have upgraded the drive to the latest firmware but still no luck.

The drive is my time machine backup so very annoying.  I am going to go out and buy a non Western Digital drive if a fix is not forthcoming

I updated to OS X Mountain Lion.  However my drive unmounts even when my iMac 2010 is awake and I am using it.  My iTunes library is on that drive.  So when it unmounts, I loose my iTunes library. 

Very frusterating.  Need to fix asap. 

I setup a call with Apple and worked through this issue.  Here is what they had me do just in case it can save someone else the time/call.

Step 1 - Shutdown your Mac. 

Step 2 - Power on and quickly press and hold Command + Option + R + P

Step 3 - While still holding Cmd + Opt + R + P, wait for the white screen and chimes to occur TWICE

Step 4 - Upon rebooting, and if you are using your external as iTunes media drive, hold OPTION and click to open iTunes

If you arent using the external for iTunes then you may not need to do Step 4.  When Mountain Lion finished and I opened iTunes for the first time, my media folder setting in PREFERNCES was empty.  So I had to set that back up, reauthorize my computer for my purchases to show up on my Apple TVs.  So those may be extra steps you may have to do if you use your external for iTunes Media as well. 

I hope that helps! 

Did re-setting the PRAM actually work for you?

I have done that but no luck, my drive still unmounts when it shouldn’t.

I have seen this discussion on other forums and the PRAM reset did not work.  I think it is a software issue with the Essential as my WD Elements drive (as well as my Drobo) all happily stay connected to my Mac.

Have the same problem with my My Book Essential unmounting when the computer goes to sleep. Have been working with Apple on the problem since 7/28 with no success thus far. 

Updated SmartWare to on 8/3.

What version of firmware do you have on your drives?

I have version 2.018 on my My Book Essential according to SmartWare. The WD website states that there is an update from 4/3/2012 to When I tried to run this firmware update the installation software stated that the current installed firmware (2.018) is the latest. Tried to install the firmware anyway. After the install, the SmartWare shows that the firmware is still on 2.018.

Comments, suggestions…

I am sad to report it didnt fix the problem afterall.  It seemed all well and good, but a few hours later it unmounted.  Since, it will unmount almost instantaniously.  Apple called me back this morning and we tried additional resets.  I had to go into work so ran out of time.  But tonight I tried a couple more things he told me as well as reinstalling Mountain Lion again.  It still unmounted.  He told me to try and restore the driver file from Lion out of Time Machine, but I dont know how to find the file.

Apple is to call me back at 11am tomorrow.  We will see where we go from here.  I insert a DVD and it spits it back out almost immediately.  However I see the contents of it mounted on my desktop with the pop up window.  Something is definitely wrong.  When I look at the system logs, there is so much going on I cant even read it because its a constant scroll of logging going on.  Just go into applications>utilities>console and scroll to the bottom where you will see the system.log. 

Lastly, Since this is my iTunes library, I have some VERY odd behavoir with my Apple TV>  Even though the drive is unmounted, my Apple TV will still see a subset of my library… even though it resides on the unmounted WD drive.  Additionally, the drive is seen by the WD Smartscan.  I can remount the drive and use it.  Its very strange indeed. 

I have to think its actually something with Mountain Lion and 2010 iMacs (not sure what year/model you all have???)  Its odd that my DVD drive will eject immediately.  My network drives seem to stay connected well enough to do Time Machine backups and such… but the Time Machine drive comes and goes anyway by virtual of the Time Machine. 

Stay tuned and lets share what we learn.  Alternatively, WD has not replied yet to my inquiry earlier this week. 

One other thing you may note to Apple if you speak to them… when I was in disk utilities via Recovery HD, I had no options for Verify/Repair Permissions.  This told the tech that the drivers or something was not functioning properly.  Additionally when I was booted into safe mode, my Video animations in the UI (ie the spotlight icons and notification bar) were very choppy and could see the screen redraw them block by block. 

So if you have that issue… I would have to think its gotta be OS/imac related. 

I am not convinced it is an Apple issue to fix.  

Whilst the update to Mountain Lion has caused the problem, I think the fix needs to come from WD (update drivers) as my other drives do not unmount.

My WD Elements Desk Top drive is fine (as are my portable drives).  My drobo (which is filled with WD Green Caviar drives) is also fine.  I think it must be something with the SmartWare software. 

I don’t have anything to support this other than my other drives are all fine.  Only the WD Essential is the problem.

I have the SmartWare Software 2.018 as well.

I also do not have verify and repair permissions as well. 

What happens when you insert a DVD into your super drive?  Also what year/model are you using? 

I am running a 2011 iMac (27") and my WD Essentials Drive is from 2011 as well (purchased at the same time as my iMac).

I have no issued with my super drive.  I can happily insert movies or any other DVD or CD’s in the super drive.

Still working with Apple tech support.

Tried setting the Sleep Timer to never in SmartWare as well as unchecking “Put had drives to sleep when possible” in System Preferences/Energy Saver. Drive still unmounted.

Confirming also that my Drobo which is filled with WD drives has not unmounted at all.

I ran Apple Hardware Test and nothing wrong.  Apple called me back this morning and we decided it was best to do 1 last backup, go into recovery, erase my internal drive, resinstall the OS fresh, and then restore what I want from Time Machine.

The believe its software/driver reated since I am having issues with both Western Digital and Superdrive. 

I wish Western Digital would put out a statement that the drives work or dont work with ML so we would know if all this is going to be worth it or not. 

Still working with Apple tech support.

I appologize in advance if this is obvious.

Ran a test last night and set the timer to “never” in System Preferences/Computer sleep. The drive did not unmount.

This isn’t the final fix, but it lets my backup drives remain connected for now so that my automatic backups will work. 

Have not had any problems with the DVD drive.


  1. Is your Mt. Lion OS-X an upgrade from Lion OS-X to Mt. Lion or clean an install Mt. Lion (without any previous operating system)?

  2. What is the Build #?  Go to Apple > About this Mac > Click Version 10.8 to find Build #.  

12A269 = 10.8.0 Retail 12B19=10.8.1

  1. How is your drive partitioned?  APM or GPT?

  2. Is the the version of your FirmWare of the My Book or WD drive?

Go to Apple > About this Mac > More Info > System Report > Hardware USB or FireWire > My Book > Firmware Revision

  1. How long does it take to fail?

  2. Is 100% reproduced?

  3. Are there any software running?  WD SmartWare or any other 3rd party SW?

  4. Have you tried 10.8.1 update? 


  1. This was an upgrade from Lion to Mt. Lion

  2. OS X Build is 12B19

  3. The drive is partitioned GPT (from System Information / Hardware / USB / My Book 1110)

  4. Firmware is 2.018 (from WD SmartWare / Settings / Set Up Drive )

  5. Not sure how long it takes to fail. I’ve never waited long enough after the computer sleeps to see the drives unmount.

  6. It is 100% reproducible.

  7. WD SmartWare version is running. There is definitely other 3rd party software running (Chrome, iTunes, Evernote, Quicken, Word, Excel, …).

  8. Already had installed 10.8.1 on 08/23/2012 and the unmounting problem still persists.

Thanks for quick reply.   I have some more questions for you.

1. Have the same problem with my My Book Essential unmounting when the computer goes to sleep.

What is the sleep time at at? (Default or custom time)

  1. What is the model of your Mac? iMac, Air, MB Pro, what year?

  2. Is it possible to uninstall WD SmartWare to see if SmartWare is culprit with 10.8.x?

You should be able to re-install and continue with previous backup plan.

  1. Can you confirm same exact environement with 10.7.x didn’t have a problem?

10.7.x + My Book Essential 2.018FW + GPT + OS-X Sleep Time ? + Same 3rd Party SW

  1. What is the Sleep timer set at WD SmartWare? (Default or custom time)?

Had previously set the System Preferences / Energy / Computer sleep to Never to stop the drives from unmounting. Set this  back to the normal setting of 1 hr. 

  1. The sleep time in SmartWare was set to 10 min. (not sure about the custom or default)

  2.  MacBook Pro 15" mid-2010, 2.4 GHZ Intel Core i5, 8 MB RAM

  3.  Uninstalled SmartWare and the drive unmount did not occur. This may be the isolation point for the unmounting problem. 

  4.  The drive did not unmount in several of the previous versions of Snow Leopard and Lion.

  5.  The Sleep Timer was set to 10 min. (not sure about the default or custom)

WD Support,

The SmartWare software is not re-installing from the VCD. The installation software is stuck with the “Estimated time remaining” barber poll with no actual time estimate. 

What should I try next?

Tried Mac 10.7> 10.8.0 > 10.8.1 + MBP 13”+ My Book Essentail with FW 2.018 + Install WDSW 1.3.4.x + OS/WDSW Default Sleep setting + Over weekend = Still Mounted.

  1.  The drive did not unmount in several of the previous versions of Snow Leopard and Lion.

I understand you upgraded to 10.8/Mt. Lion from 10.7/Lion.  What was your original OS?  Was it 10.6/Snow Leopard?

Another words, did you start OS with 10.6 and upgrade to 10.7 and upgrade to 10.8 again?

Or, was it just from 10.7 to 10.8 upgrade only.

  1.  Is it possible to partition to your internal drive or use external drive and make a “clean” 10.8 OS Boot drive/partition and install WD SmartWare and run your test again?

When I say Clean, straight installation of 10.8 Mt. Lion without any upgrade.

  1.  Can you think of any other ideas on how I can reproduce your issue?