3 TB windows 11 Compatibility?

Hello all. I have recently purchased WD My Book essential 3tb External Drive, of which I have torn open and found the Western Digital 3 tb wd30ezrx. I have been trying to attach this to my pc for quite some time. When I first got it, I plugged in the the new sata data cable and a second sata power cable that was also connected to the first hhd. Nothing happened.

When I say nothing happened, I mean it. The start up screen did take a bit longer, but when I finally got into my pc, there was no drive. When checking Device Manager and Disk Manager, there is no new drive. It is not, in fact, just the file explorer not finding it, the entire computer can not see it
I then tried swapping the data cables for the 2 hhd’s. Still nothing happened. the old D: drive was still there, and no new drive.
I tried swapping the power cables but not the data cables. Still nothing.
As I am typing this, both the power cable and the data cables are swapped, with the ones that used to work on my old hhd now plugged into the wd30ezrx, and the new cables plugged into the old hhd.

after a bit of searching, I found the Amazon page, and it stated that it had compatibility with Windows 7/Vista. Surely this was only writings of its time, and not a fact that it would not work with Windows 8/10/11, right?

1 Like

Hi @Neverhead
Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

1 Like

I have been wondering about Windows 11 compatibility with my 3TB drive too. From what I have gathered, Windows 11 should support it just fine. Microsoft’s official requirements don’t mention anything specific about drive size, so I think we’re good to go. However, it is always a good idea to keep an eye out for any updates or announcements.

I can understand how much trouble this has caused, First, make sure the drive is properly connected to your PC and power supply. Check if it shows up in BIOS/UEFI settings. If not, try different SATA ports and cables. In Windows, check Disk Management to see if it’s there but not initialized. Also, look in Device Manager for any driver issues. Test the drive on another computer to rule out PC-specific problems. If it works there, the issue might be with your PC’s configuration. Ensure your BIOS/UEFI is up-to-date, and consider trying a firmware update for the drive. If all else fails, the drive may be faulty, so contact Western Digital for support.

IF you read my post, you’d READ that I HAVE checked the disk management app, I HAVE swapped the cables multiple time.

I sent the disk to a repair store. Apparently the partition was deleted, so he fixed that bit. When I plugged the hdd in again, however, it showed up for 1 minute, said it wasn’t partitioned properly or something, and is now missing again.

I have swapped the data cables again. Just to make you, Esther, happy. The hdd isn’t showing up again.

I am bringing my entire computer to the repair guy. Maybe he can be of more help.