1 TB PiDrive HDMI not working using BerryBoot

Hi everyone,

I was wondering if anyone ran into the issue of the PiDrive running but the HDMI port isn’t working for the PI 3. This is my 3rd raspberry pi 3 that seems to not work at all after plugging in the pidrive. The 1st PI3 worked for about 2 weeks & after replacing the PI 2 times after that, I’ve come to the conclusion that the 1TB drive is way too powerful to keep the HDMI port from burning out. If anyone has a solution for this it would be very helpful as i initially loved this product while working for those 1st 2 magical weeks before this disappointing stretch.

I’ve been running a 4TB My Passport Ultra (which consumes more power) for over a YEAR on my RPi3 without any HDMI problems. Using a 5V 2.5A Genuine Raspberry Pi PSU.

The 1TB PiDrive consumes less power, so i can’t see that causing the problem

Just a example … my 2TB WD Elements only consumes 0.22A


and my 314GB PiDrive draws 0.21A

Hi harm4real,

Are you getting no output on your HDMI monitor (black screen and/or monitor reporting no signal)?
When it stopped working, was it active/working or wouldn’t work after a reboot event? If active/working, what application was running when it stopped?
Have you tried a different HDMI cable and monitor?

Do you have a different microSD card with OS preloaded (e.g. NOOBS, Raspbian, etc.) that you can try in the R-Pi (instead of the Berryboot SDcard; you can leave the PiDrive attached) to confirm that the video still doesn’t work? This would be a way to check if the Berryboot SDcard might have become corrupted somehow (although it doesn’t really match the symptoms you describe).

I haven’t experienced video issues related to powering except in some situations using the Official R-Pi 7" Touchscreen display.

If possible, it would help to see a photo of your setup; you can email it to me at dave.chew@wdc.com if you want.


Hi, looks like the HDMI is working now but the SW is not seeing the drive properly. What 5V adapter are you using (amperage, brand/type)? What type of cable are you using between the 5V adapter and the PiDrive cables (i.e. what length? manufacturer?).

It also may be that something may have become corrupted. In this case, I would reformat the USB drive using a host PC, then try it again in the Pi. If same error, then I’d reformat and re-image the sdcard (i.e. download WD-Berryboot and unzip it to a freshly-formatted sdcard), then try it again in the Pi.