Zugriff auf Mycloud unter Windows 10


#1

Hallo Community,

vorab möchte ich anmerken, dass das hier angesprochene Thema bereits schon mehrfach gepostet und kommentiert wurde. Der Übersicht wegen möchte ich aber nicht in die älteren Threads meine Fragen und Kommentare einstellen, weil die Themen auch bereits abgeschlossen sind.

Alles was ich bisher in Bezug auf meine Frage gelesen und geprüft habe, klingt plausibel und logisch, hat aber nicht zur Lösung meines Problems beigetragen.

Aber ich denke ich habe da doch eine echte Rätselaufgabe …

Also erstmal die Hardware:

1 PC mit Windows 10 Home
1 Notebook mit Windows 10 Pro
1 myCloud 2TB

Nun die Konfiguration:
Auf den Rechner gibt es identische Benutzerkonten
(Benutzer A, Benutzer B und Benutzer C)

Auf der myCloud sind für jeden Benutzer ein persönlicher Ordner mit entsprechenden Zugangsdaten angelegt.
Da der Benutzer A der Admin ist und auch die Daten pflegt, hat er Zugriffsrechte auf die Ordner B und C.

Zusätzlich gibt es auch noch einige gemeinsame Ordner die öffentlich sind.

Jetzt das Problem:
irgendwann mal hat es vom PC funktioniert, dass der Benutzer A auf die Ordner auf der myCloud zugreifen konnte. Da das super war. hat er also irgendwann WD Sync eingerichtet um seine Daten vom PC auf der NAS zu sichern.

Dann hat der User A sich an den NB hingesetzt und die Zugriffe geprüft.
Uns alles schien i.O.

Irgendwann hat User A aber versucht von seinem PC wieder auf den für ihn mit freigegeben Ordner von User B zugreifen zu wollen.

Und er bekommt die bereits gepostete Meldung, dass ein Mehrfachzugriff nicht möglich sei.
Alle Versuch mit einem der 3 Benutzer raufzukommen schlagen fehl.

Das irrwitzige ist aber, dass es vom Notebook mit den entsprechenden Zugangsdaten geht ???

Also hat man jetzt folgendes gemacht (immer mit Neustart):

  1. hinterlegte Anmeldeinformationen geprüft und gelöscht - (hat nicht geholfen)
  2. gesamtes Mapping entfernt - (hat auch nicht geholfen)
  3. sämtliche WD-Software vom PC entfernt, weil könnte ja sein, dass die hier mit reinwurschtelt - (hat auch nichts geholfen)

Als nächstes habe ich die These geprüft, ob es an der Anmeldung mit IP und NS liegt.
Für den PC ist der Stand:
Anmeldung über Name geht nicht
Anmeldung über IP klappt

Für den NB ist der Stand:
Anmeldung über Name klappt
Anmeldung über IP klappt
ABER: wenn der USER C sich angemeldet hat und man dann auf Ordner von A gehen will kommt ja wie erwartet die Anmeldeabfrage. Aber dann musste ich feststellen, dass man sich nicht mit dem anderen User anmelden konnte. Wieder diese Mehrfachanmeldeproblematik, die man aber mit dem Wechsel von IP auf NS oder umgekehrt schnell löst.

Nun gut ein User meldet sich natürlich nur da an wo er rauf möchte und wechselt nicht immer die “User”. Da ich hat mit dem A überall rankomme ist das OK.

Was mich stört ist das Problem auf dem PC, weil es dort über den NAMESERVICE nicht bei der myCloud geht (nur auf die öffentlichen).

Und wo zum Teufel :imp: speichert Windows 10 die Zugangsdaten für eine Netzwerkfreigabe noch.
Unter Anmeldeinformationsverwaltung ist hier nicht hinterlegt.

Wenn ich den Rechnerneustart ist ja beim Zugriff erstmal die erst Abfrage logisch, dann scheint Windows aber entweder mit admin User weiterzukommen oder wenn sich ein eingeschränkter User “erstmalig” angemeldet hat, geht keine weitere Anmeldung mehr weil dann wieder die Mehrfachanmeldung angemeckert wird.

Ich kann nur feststellen, dass es an der WD-Software wohl nicht gelegen hat.

Also wenn hier jemand durchblickt und mir vielleicht einen Trick verrät, wie ich sehe, welcher User gerade welche Verbindung zur NAS “gekappert” hat und wie man sie trennen kann, wäre das total toll.

Ich hoffe ihr seht hier durch :wink:


Loginprobleme bei der My Cloud
#2

Hi,

ich hab das noch nicht so ganz verstanden mit … [quote=“ROCCO_K, post:1, topic:193440”]
Anmeldung über IP klappt
[/quote]

Kannst Du mal einen screenshot einstellen wie Du das meinst.

Ansonsten kann ich nur empfehlen Windows fremde Produkten (dazu gehört auch WD Software) sparsam einzusetzen. “Nur Backup” läßt sich auch mit Windows gut realisieren. Aber jeder wie er mag…

Gruß
Lucky


#3

Entweder meldet man sich über die IP-Adresse (z.B. \192.168.178.200) oder eben über den DNS-NAME (z.B. \mycloud). Je nachdem ob ein Ordner mit entsprechenden Zugriffsrechten versehen ist, muss man sich authentifizieren.

Die Meldung: Wegen des verweigerten Zugriff lautet:
Mehrfache Verbindungen zu einem Server oder einer freigegebenen Ressource von demselben Benutzer unter Verwendung mehrerer Benutzernamen sind nicht zulässig. Trennen Sie alle früheren Verbindungen zu dem Server bzw. der freigegebenen Ressource, und versuchen Sie es erneut.


#4

Hi,

hier noch einmal etwas was Dir bei Deiner Recherche vielleicht weiterhilft:

" …Eines müssen Sie in jedem Fall beachten: Windows kann sich zu einem Server (anderen Computer) im Netzwerk nur unter jeweils einer Identität verbinden. Das heißt, Sie können sich nicht gleichzeitig als peter und lukas verbinden. Besteht eine Verbindung als peter, müssen Sie diese zunächst trennen, ehe Sie sich als lukas verbinden können. In der Eingabeaufforderung liefert „net use“ eine Liste bestehender Verbindungen, die Sie mit net use \server\freigabe /del trennen können. (ps)…"

Gefunden hier : https://www.heise.de/ct/hotline/Als-anderer-Benutzer-im-Netz-948303.html

Gruß
Lucky


#5

Das klingt ja plausibel aber passt nicht.

Bsp.
Es gibt
Benutzer A mit Passwort A auf Freigabe A
und
Benutzer B mit Passwort B auf Freigabe B

  1. Benutzer A setzt sich an PC1 und geht auf \Server\freigabeA. Er muss jetzt sich mit Daten von A anmelden.
    Die Accountdaten werden nicht gespeichert. !!! der Haken “Kennwort speichern” bleibt draussen !!!
    Es gibt auch kein Mapping (net use)
  2. Jetzt will Benutzer A am PC1 auf \Server\freigabeB. Hier soll er doch mit den Daten von Benutzer B raufkommen.
    Also Anmeldedate angegeben. Nicht Speichern gewählt.
    –> Geht nicht! Mehrfachanmeldung nicht erlaubt.

Was nun: Rechner neustarten und dann das selbe noch mal in umgekehrter Reihenfolge mit der ersten Anmeldung auf FreigabeB mit User B sieht gut aus , aber wenn Freigabe A dran ist geht es wieder nicht.

Übrigens: Wenn man dann wieder auf den ersten User geht, mit dem man sich anmelden konnte, kommt man auch da wieder rauf ohne sich erneut anzumelden.
Und es gibt keinen sichtbar hinterlegten Anmeldedaten hierfür. Unter “net use” wird man auch keine bestehende Verbindung sehen, weil es ja keinen gibt.

Windows schein hier aber irgendwo diese Client-Serververbindung temporär zu hinterlegen. Diese verschwindet erst, wenn der Rechner neugestartet wird. Und dann muss es hier noch Unterschiede geben zwischen Windows 10 HOME und PRO in Bezug auf Verbindungen über IP-Angabe oder Namensangabe des Servers geben, weil ich auf HOME über Namen nicht raufkomme. Lustig ist: vorher hatte ich eine andere NAS und da ging es.


#6

Hallo,

ob es dem NAS zuzuschreiben ist, kannst Du ja mal testen, indem Du über die Oberfläche das Gerät neu startest und hiernach mal User A bzw. B versuchst…

Gruß
Matthias


#7

ist bereits mehrfach geschehen - ohne Änderung.


#8

Hi,

doch, paßt genau. Der Artikel gibt genau das wieder was Du wiedholt darstellst (und bei mir ganz genau so ist).

Du meldest Dich als User “A” an … dann geht nichts Anderes mehr - nur der Zugriff als User “A”. Und das Ganze (die Anmeldeinformation für Windows) bleibt so lange erhalten wie Du mit diesem Windows-User angemeldet bist.

Erst wenn Du Dich (Windows User) abmeldest (… ein Runterfahren des Windows-PC ist nicht nötig …) kannst Du Dich dann als User “B” anmelden.

So steht es beschrieben im Artikel - und genauso funktioniert es auch bei mir. Und wenn Du etwas anderes Möchtest, das mußt Du unter Windows mit dem Befehl “net” arbeiten und Dir ggf. ein kleines Batch Programm schreiben.

Das hat also Nix mit Eigenarten der MyCloud zu tun, sondern ist ein Windows Problem. Vielleicht gibt’s hier ja ein paar Linux/MAC - User bei denen es anders ist.

Gruß
Lucky


#9

Ja du hast recht. Leider dreht man sich doch mal im Kreis.
Das ist eben ein Problem von Windows.

Besonders wenn man z.B. auf auf unterschiedlich berechtigte Freigaben zugreifen will und sich mit den entsprechenden Freigabe Daten anmelden möchte. geht das ja nicht.

Die Option bei der Netzlaufwerkverbindung “Mit anderen Anmeldedaten verbinden” ist dann völlig für den A…! Dann kann man sich demnach als Laufewerk X von Freigabe A mit den Anmeldedaten User A einbinden und sich noch noch mit Freigabe B über User B mit dem Laufwerk Y verbinden. Bullshit …

Ich hatte jedenfalls nochmal mit dem SMB-Eintrag gespielt uns von 2 auf 3 und später wieder auf 2 gestellt. Nach dem letzten NEUSTART der NAS komme ich jetzt über //SERVERNAME/Freigabe??? rauf. Aber eben nur mit dem User der sich gerade auf die jeweilige Freigabe eingeloggt hat. Aber was mich immer noch stört ist, dass Windows sich irgendwie immer noch diese Verbindung merkt. Ich habe unter Net use nachgeschaut und die vorhanden Einträge in der Liste gelöscht. Trotzdem komme ich nicht an die andren Freigaben ran. Erst nach Abmeldung / Neustart des PC (oder eben der NAS).

Aber ich werde es mal mit eine kleinen Batch zum trennen der Verbindungen versuchen.
Danke erst mal.


#10

Hi,

Guten Idee. Und … immer wieder gerne…:innocent:

Dann mach mal zu hier

Gruß
Lucky