YuppTV not loading with WD TV Live hub

Hello,

I purchased the WD TV Live hub today (Model WDBACA0010BBK). I am able to play services like Youtube. When I goto Movies & TV, click on YuppTV, screen just stays blank.

  • Which firmware? 3.08.14
  • What happened? YuppTV does not load. It shows a black blank screen when opened.
  • What were you doing? Clicking on YuppTV within services -> Media & TV menu.
  • Does this happen every time? Yes.
  • What hardware and media were you using? WD TV Live HUB - WDBACA0010BBK EESN
  • Did this happen with previous firmware? I dont know. I have bought this new.
  • Does power cycling the unit solve this? No.
  • Does resetting to factory defaults solve this? No.
  • Have you tried this on other devices? I have tried YuppTV on PC and Android tablets. Not on any WD devices.

You can try resetting the device and also testing the services on a different device to see if is an issue with the media player or the online service.

I checked with YuppTV. They told me that there is a problem with the app in WD Live TV hub. They are trying to work this out with WD, but WD has provided no plan on when this can be solved. So they suggested me to switch to WD TV Streaming player (Gen 3), and Media Markt was kind enough to exchange even thogh it costs only 1/3 rd. 

Now I am watching YuppTV without any problems.

Request to WD: Please be proactive and ensure that your apps works well, Otherwise customers would settle down for lower prices models or other brands where it works !!!