Yet another Western Digital My Passport driver problem

First off, let me just admit that this problem is wholly of my own making. It’s my fault for futzing with a perfectly good working situation and screwing it up by messing with drivers. Yes, a cardinal sin in Windows world, I know. But just in case someone out there is an expert willing to help, I’d appreciate it very much.

I have a Western Digital 1 TB My Passport USB 3.0 drive, model number wdbbep0010bbk-03. The drive was working just fine on my self-built PC, running Windows 7 Professional x64. I perceived some slowness in the USB 3.0 transfer rate and decided that I needed to install the SES driver from Western Digital, which led me to uninstall the drivers for the device, restart the computer, plug the drive back in and let Windows find the drivers. Alas, this did not happen. Windows just said that it didn’t find any drivers for My Passport 07A8. There was no mention of SES drivers. When I forced the SES drivers on the hard drive (downloaded from Western Digital), they installed but in Device Manager, Western Digital Drive Management had a yellow exclamation mark and nothing worked. During all this, the drive does not show up in Windows Explorer or in Disk Management.

I plugged the hard drive into a W7Pro x64 machine at work today to see what happens there, and Windows Update automatically installs the hard drive in two places in the Device Manager, one under Disk Drives listed as My Passport 07A8 and then under Western Digital Drive Management as SES Device. The drivers listed for the first instance are the typical drivers for any external USB hard drive connected to a PC: disk.sys and partmgr.sys (and maybe iaStor.sys?). Basically, what I think I’ve done is I uninstalled those drivers that are simply part of Windows, although other USB disk drives that apparently use those drivers work just fine on my home PC. Maybe I uninstalled the drivers’ association with this particular hard drive?

Any cursory examination of this board or the forums over at Western Digital and other places online shows that I am not the only one with this issue. I have tried all sorts of things, and have restarted my computer an umpteen number of times and each time I plug the hard drive in the same result happens. When I tried to point the hard drive towards the drivers, whether they are Windows drivers or the SES drivers supplied by WD, they still would not install. I tried removing all instances I could find of the hard drive anywhere. I tried this registry thing I saw online, talking about UpperFilters and LowerFilters. Deleting those registry keys just meant my computer wouldn’t start, so I had to go back to last known good configuration, so that didn’t work either. Anyway, I guess I’m here to see there is something completely obvious I’m missing somehow. I consider myself a fairly experienced computer user and I think I’ve systematically tried to go about this, though some of my irritation at myself for creating this problem where there was no problem meant that I maybe went about things too fast sometimes and might have missed something.

The drive by the way works just find on my Mac laptop and on my Ubuntu server (showing the two partitions, one exFAT and one NTFS, without any problem). I updated the firmware on the drive just in case, no change. I’ve tried all the USB sorts, in front and back, 2.0 and 3.0, with no luck. The drive doesn’t need extra power as it runs off my old Macbook just fine and of course was working fine before I screwed up the drivers. I’m wary of using any of those driver cleaner utilities that hang about dubious looking websites online, but maybe someone can recommend a trusted tool? Maybe Ccleaner will/can do the job? Do I need to delete partmgr or disk.sys from my system32 folder? Is there an .inf file I need to point the drive to somewhere? Can I take the partmgr.sys and disk.sys from the Windows 7 computer at work and replace my own files with those and see if that works?

Thank you in advance to anyone willing to help, cheers.

1 Like


I recommend you contact support directly for assistance with this issue.

Contact WD