Yellow LED Blinks Forever (Factory Reset Didn't Work)

I got my WD MyCloud about 5 days ago.

Plugged it in, transfered a few files. Accessing them was working.  Everything was fine. I updated to the newest firmware (can’t remember the version stamp now, but it was the lastest as of 20.11.13).

Around 2 hours after having first pluged it in I tried to setup a static IP address (via the MyCloud web interface) so I could start configuring my router/modem to allow the ports necessary so that I could access the MyCloud from outside of my homenetwork. 

Ever since I did that the LED has blinked yellow. To be clear, when I start it up the LED blinks white once, then remains white. After about 30 seconds (though I haven’t timed it, just a guess) it begins blinking yellow. I’ve left it sitting blinking for well over 2 hours.

Things I have tried:

— Multiple ethernet cables (as I know this is supposed to be a sign of lack of connection).

— Quick reset by holding the reset button down for 4 seconds.

— Factory reset by holding the reset button down for 40 seconds as I power up the unit. 

No matter what I do the LED continues to blink yellow.

If I look under the DHCP settings in my router it’s definitely assigning this device an IP, and what’s more it’s not the IP I had manually (tried to) assign it. So I can only assume it has factory reset in some way.

To this point though, when factory reseting (as far as I can tell) there’s no way of determining that the factory reset has taken place. Hardware wise I mean. No instant change in the light or a beep to signify reset. This is the first product I’ve ever used that doesn’t give it’s user some feedback on reset. An odd omission.

Anyway, back to my issue…

When I try to access the web interface via it’s supposed assigned IP - with “/UI” affixed - I get nothing. Literally nothing. Not the browser throwing up it’s usual “Page not found” error. Not a loading indicator in the browser. Nothing.

I’ve scoured the web and the WD forums for answers and I’m pretty sure I’ll have to send back the device. The thing is, I really don’t want it to be broken. Not because I care about the files on there (I hadn’t transfered enough to care about yet) but because if it’s broken I don’t want a replacement, I want my money back. Honestly, how are we supposed to trust this product with all of our files.

I guess I just can’t believe this product failed on me after only 2 hours use.

If anyone could shed some light on this I’d really appreciate it. If Ihaven’t supplied enough detail, please, ask away.

Have others had units replaced? Have those new units been more reliable? Is it a firmware thing? I really want to believe in this product, but I need my faith restored.

Thanks in advance

Sadly to say but you are not alone. :cry:

Mine bricked after 3 days of use and i tried all you said without result (no net, no SSH, nothing) only blinking yellow.

Early adopters are prone to this kind of problems.

UNBELIVEABLE! Same to me after only 2 days!!! 

Is really impossible to fix it without sending the item back? Any suggestions?


Solved at least for me: