How to unbrick a totally dead WD My Cloud

Nice to meet you.

My mistake. WMC to repair the brick I would like to state.

Look at the contents of the following MBL 2TB can get the IMAGE ISO.

The same way.

Maybe someone of WMC 2TB IMAGE ISO would like to know how you can get.

Or if you can suggest another solution curious.

Obtain answers to those wonderful.

Have a good weekend.


Thanks for sharing.

1 Like

Well i wil try to do a long story short, after this thread:

Guide to direct backup, unbrick , disassemble process (video) like MBL ones?

If you do the following AFAIK you are voiding the warranty!

I opened the “box” and connected it directly to a linux system via sata (could be USB-SATA or ESATA also).

I ran gparted and the disk partitions layout was the following:

I saw the disk has 8 partitions and the layout seems correct so i did it the easy and safest way i thought.

I closed gparted and from the file manager i browse to the ext4 partition labeled “data” from  the folder “shares” , i was lucky to recover all of them to a different disk!

I ran the util “Disk” from lubuntu other distros have similar tools.

I selected the WD 3 TB disk and just in case of even worst disaster i made an image copy (.img) of both raid partitions the ext3 1.9 GB ones.

Finally i write over each raid partition the rootfs.img image i extracted from the last firmware for My Cloud using 7zip.

From i unzipped  sq-030104-139-20131028.deb and unzipped  data.tar  and unzipped the folder CacheVolume inside it there is the folder Upgrade and inside it the partition image rootfs.img with 1.9 GB in size.

I shutdown the PC and connect My Cloud with only the mini board network cable and power supply to my router.

After a few moments i saw the BLUE LED :).

From the browser i navigate to and setup my My Cloud after doing a Utilities-System Factory Restore-Quick restore to be in the safe side ( didn’t touch the other 6 partitions on the disk).

This is just my case but for me a least it works again.

Since i don´t trust this piece of hardware anymore i do daily file sync to it from the 3 TB disk i bought to save the data from his soft brick.

I made several pics of the disassemble and i will post them if anyone ask for them.


sammarbella wrote:


I made several pics of the disassemble and i will post them if anyone ask for them.


Could you please post the pictures of the disassmebly? It will be of help to me.

OMG~ Your My God~

Thank you so much for being a great help.

This afternoon I will be on your way to apply.

Hopes to resolve because of you.

Hope you always happy.

Thank you.

Nice work.

Yes the pics would be nice.

Images are high res so i can paste them in this post folow this SkyDrive link:

MyCloud 3TB dissasambled

Which image writer software you were using to write the rootfs.img to your raid members?


1 Like

I cannot figure out how to extract the rootfs to the raid disks, can you please explain more precisely how to do that?

bogoewsky wrote:

I cannot figure out how to extract the rootfs to the raid disks, can you please explain more precisely how to do that?

It’s not extract is write on selected partition via “restore disk image” option as follow.

In the other thread i posted this:

sammarbella wrote:

cnlinya wrote:

Next step, I want to copy the system file into related partition.

:smiley:Can anybody tell me how to do this step?

You can write the system OS image like JRman wrote is the easiest and fastest method.

If you are a GUI guy (like me)  you can write it using a GUI tool like i said in the other thread download the firmware unpack the system OS file rootfs.img and use disk utility from your ubuntu ( i did in lubuntu but it should be the same).


Unzip to get sq-030104-139-20131028.deb.

Unzip to get data.tar.

Unzip data.tar to get a folder named CacheVolume.

Inside CacheVolume there is another folder named upgrade.

Inside upgrade there is a bunch of files the needed is rootfs.img

Open disk util in ubuntu (disk, disks, gnome-disks several names…just alt-f2 "gnome-disks) select the first raid partition in MyCloud HDD , click on the gears icon (the one in the middle of the util screen)

click on “Restore Disk Image”, browse using the combobox and select rootfs.img.

Click open and finish the write process, repeat these steps with the second raid partition, close util, shutdown system, reconnect HDD to miniboard, ethernet cable to router and power supply.

If Partition layout is ok and hardware is ok this should recover a soft brick in MyCloud.


Hi  sammarbella,

I have tried your method to recover my bricked WD My Cloud, but unfortunately my partition table was messed, so writing the image was not enough.

I have created manually the same partition table you have and written the rootfs.img in both raid partitions and… red light.

I have mounted the virtual raid in my PC and flash it to the virtual raid… red light

I have used the for the WD Book Live with some modifications for this model… red light.

I even tried to chroot the OS in a USB stick and execute the but the hard drive’s file system is still in use =(

With the .img I’ve seen in the forum, it works but the partition table appears as corrupted on my pc and I cannot connect it directly in case the system breaks and I want to recover the data.

Any ideas?? :\

Recover data first if you can with the recovery soft.

After that erase everything (all partition) in MyCloud disk and use the full disk image to restore (write) the full disk image (all partition and same layout from the gear button who is up and to the right in the “disks” window.(the 2 gears button in the middle are for partitions only).

Yes, I did that, and the device works, but when I plug it in my PC, it appears as corrupted and I cannot see any partition or file.

Is that normal?

When you plugged on your pc???

What that means???

After you delete all partitions on HDD and write the full disk image on the HDD you must shutdown your linux (or live linux system).

Then you connect the HDD again to the miniboard of MyCloud, connect ethernet cable from miniboard to router and power supply and boot the device.

At this moment you “can’t see partition” you may see device as whole on local network and be able to connect to dashboard via browser.

I mean that after writing the image, the device works, everything is ok…

BUT!! =( if I connect the HDD again directly to the computer (to restore data for example), neither linux or windows see the partitions in the disk.

If I connect the HDD to the PC directly and run gparted or parted on my PC, it doesn’t recognize the partition table.

If I connect the HDD to the microboard and run parted on the board by ssh, it recognizes the partitions =S.

Its really important for me, because everytime I want to restore the system (I “play” with it a lot, so high risk to brick it), I don’t want to lose all my data!!

Does it happen to me because I restored the image or does it happen to everybody???

I saw that flashing rootfs.img to the raid partitions works to restore for some people, but in my case I can’t do that because the partition table seems incorrect if I plug the drive to the PC.

Yes, I use gpart, and it says the GPT table doesnt exist or is corrupted.

I think this is because GPT tables are in the begining and end of the disk, and this image is only the first 5GB…

I tried restoring the first table to the backup (in the end of the disk), but doesnt work =S

use gdisk instead of gparted in order to check the GPT-partition table. I recovered mine yesterday with the help of



I hope this helps you too :slight_smile:

No, because the unit works =S

And if I run gdisk or gpart (inside the unit via ssh), it says it doesnt have errors anymore, but if I connect the drive to my computer via USB (with SATA/USB adapter), doesnt even recognize the partition table =S

Hello. I’ve  bricked my Cloud via SSH (optget unsinstalled almost all packets, including Apache).  I dumbed images from those raid partitions to my another drive, and put rootfs.img on it, but still no luck. What else I can do?