Wow! Does this thing ever work?

“No Supported WD Devices Found”  That’s the message I frequently get.  Sometimes when I reset MyCloud and rebood my computer it comes back.  Sometimes it doesn’t.  And now, after a recent software update download from WD, when it works, it thinks some photos are videos and the file folders are all messed up.  What is with this drive?  I spent the last several weeks ripping over 200 CDs and storing the files on “MyCloud”.  I’m beginning to think that I wasted a lot of time.


After the firmware update, did you reset the unit?

Also have you tried setting up  the unit with a static IP?

Look WD friend: the guy said it worked before and now after the firmware update it doesn’t work anymore.

We were smart enough to get it working under v.3, so stop telling people who’ve been through the pain of getting their MyBooks working once to do obvious things like “resetting” and unplugging and plugging back in and using static IPs. Yes, we know.

What we need is a firmware that works.

I’m not even going to talk about my two WD USB drives no longer being accessible via MyBook after FW v.4.

80% of the answers from WD that I see on this forum are lame L1 advice that everyone who’s lived with these products for a few months has tried endlessly.

Get your stuff together, moderators, and give us advice you know works rather than “try this” and “try that”.


The WD Community was created for Users -such as yourself- to help one another and to share your experiences and ideas with one another. As Moderators or staff, we are simply here to facilitate and oversee the Community. If you have a question or issue related to the WD Community itself, Moderators will be happy to respond and assist you. However, if you are looking for technical support from WD, you will need to contact them directly.

To Contact WD for Technical Support:

I’m aware of how the forum works. As for technical support from WD, that’s the issue, isn’t it? We all need support from WD, since they wrote the firmware.

Don’t mean to rain on anyone’s parade, but if there was a useful post in the scores that have been made since ver.4 came out, I’d be the last to complain. But the miles of posts going back months (and years) about WD products not doing what people expect them to is a little absurd (to me).

Just my additional 2cents. Cheers.