Won't play mkv files

Here is my issue and I hope someone can help me. For the past few weeks, whenever I try to play a newely added movie from my external hardrive on my media player, I can’t play it. The movie folder shows up on the media player but when I open it, all that is on the screen is THERE IS NO MEDIA AVAILABLE FOR PLAYBACK. This has never happened before, But for some reason the past few weeks whenever I try to play a recently added movie that is what I get. I know the movie is on the hard drive because I can play it on my computer from the hard there. The firmware recently updated, I thought that may be the issue so I went back to the old firmware. That didn’t help. I pressed the reset button and went back to the orginal setting and that didn’t work ether. It is very strange, also when I tried to add the movie to a different movie folder ( horrible bosses 2 to the horrible bosses 1 folder) I got the same message in the folder for both movies. I deleted the new movie and I still wasn’t able to play the first movie. I am so frustrated, I tried to look this issue up but everything I found was no help. If anyone can help me out that would be much appreciated.



Welcome to the Community.

Is this happening with old movie files well (Files that worked in the past)? If so, then it’s possible for the new files to use a codec profile not supported by your WD TV. If possible, please share the MediaInfo of affected files with the WD Community for analysis: