Wireless not working

#1

I’ve been trying to set up wireless internet on my WD TV Live Hub Media Center, I purchased one of the supported adapters (TP-Link Wireless N USB adapter) Model (TL-WN821N). In network settings there is nothing about wireless set up, when plugged in nothing appears. I’ve tried following instructions from many different sources and manuals and nothing is working.

#2

Unless the version of your adapter is 2.2, it is not on the supported list.

#3

Assuming your adapter is on the approved list, try plugging it into the PC usb and set it up that way according to adapter instructions, then put it into the WDTV usb and see how it goes.

#4

Hi Mike - have a very similar problem - I am trying to use a D-Link adapter to achieve the same thing. I tried your suggestion and ‘established’ the adapter on my laptop. The instructions that came with the adapter advised ‘do NOT plug in adapter until AFTER using install disc’. The install process copies the adapter ‘driver’ software to the laptop. It seems that the physical adapter is nothing more than a transmit/receive device. The driver on the PC is ‘handling’ all the actual data communications. I used Windows Settings menu to disable internal ‘built in’ laptop Wi-Fi driver and enable the D-link driver. Install put the driver in a specific place so ‘Windows’ knew where to find it. That al worked and I connected to Wi-Fi using d-link.
I think the Live Hub Mochi o/s polls the USB ports but unlike Windows it is expecting the adapter device to ‘manage’ the comms to modem i.e. the adapter drivers are on the adapter itself and not running on the live hub . Presumably Mochi firmware has ‘built in hooks’ to a number of the adapter drivers - the list of ‘tested’ adapters ?.
Any ideas on how Mochi ‘hooks’ into adapter drivers ?. I could copy the drivers from my PC to the Live hub but then how to tell Mochi to run the adapter driver and tie it to a USB port ?
Grateful for any feedback - should surely be easier than this!
Cheers
Pete

#5

Hello, I know nothing about Mochi nor can I answer your question.

Nevertheless, I had my adapter working correctly but the 2.4G signal is bad news for 1080p video, because it is too slow. 5G would be better, but the WDTV can’t use 5G, so I came up with a Plan B.

Plan B consisted of using what is called an AC wireless media bridge which converts an AC/5G wireless signal into a wired ethernet signal I could plug into the wired port of the WDTV, and it works great. WiFi as fast as wired.

The product I chose is a discontinued WD product called My Net AC Wi-Fi Bridge. If you google for this you should still find one for sale.

That is my best advice. Good luck.