Wireless Network Not Found


I purchased a WD TV Live Streaming Media Player today from Best Buy.  I followed the easy setup guide (plugged in the power cable, then the HDMI cable, then selected english as the default language, then chose to connect to my network).  After a couple minutes of searching, I get a message that says 'Wireless network not found.  Please check your settings and try again.".  Originally the box was in my bedroom in the back of the house so I thought that it might be too far from the wireless router.  I moved it to the living room which is maybe 6 ft. from the router and got the same message.  I’ve read a few posts where it reads like people have purchased USB wireless adapters and plugged those into the WD and it’s solved the problem.  I am hesitant to do this as the WD is supposed to have built in wireless capabilities.  At this point, i’m at a loss.  

I don’t have a cable long enough to try it with a wired connection at the moment.  I’m using a Negear WNDR3700 dual band 5GHz router.  I’m currently using WPA-PSK [TKIP] + WPA2-PSK [AES] security and I do have SSID broadcasting enabled.  Any help would be greatly appreciated.  I would like to figure this out as i have a lot of media I can stream and didn’t see any other options that provide that ability.

Thanks for any help you can provide.

You can’t add a USB wifi interface.  None are supported.

make sure your 2.4 ghz SSID is being broadcast as well, as the WDTV is 2.4 ghz only.

Try setting your 2.4 radio to G-only or B/G mixed, as well, just for troubleshooting.

Thanks for the suggestions.

I verified that SSID is being broadcasted for the 2.4 ghz.  I also changed the mode from ‘up to 300Mbps’ to ‘up to 130 Mbps’.  I guess the 300 is for a/n and the 130 is for b/g/n.  

I disabled the SSID for the 5 ghz.

In the advanced wireless settings, i also disabled the 5 ghz wireless router radio.  From what i’ve ready, this should basically stop the router from transmitting in that frequency.  Figured it couldn’t hurt.

The router has been re-booted numerous times now, along with having it’s firmware updated to the newest version.  

Unplugged the WD, plugged it back in…same result.  Not sure what else to try at this point other than taking a TV into the room with the router and trying it with a LAN cable.


Only other suggestion I have is to see if you can take it over to a friend’s house and see if it can detect their network.

It’s possible the WiFi interface on the SMP is dead, and that would help narrow it down.

I’m having the same problem.

Set up the SMP and did a search for wireless networks and it doesn’t find anything, despite my BT Homehub 3 router being about 4 feet from it! I don’t think there’s anything wrong with the router as the wireless works fine for my iPhone and iPad, as well as being able to access other laptops on the network in the house.  

The only saving grace is that because the router is so close, I can connect via ethernet.  However, and I missing out on any features by not having wireless connection?  I assume that I should be able to still access media stored on laptops connected wirelessly as long as they are connected through the router?

That’s correct.  If wired is a viable option, ALWAYS use it.