Windows11Pro - Can't access files

Hi, I’ve purchased my WD My Book, a couple of years ago.
Then, two years ago, I’ve bought a new Windows 11 Pro desktop computer.
Since then, I can’t access lot of my files, especially photos.
I’ve tried to solve this by changing their Windows security permissions, But I have so many of them.
Can you provide me with a better and quicker solutions?
I will appreciate your kind help.

Hi @AsafPreiss,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

I found that the MyBook stuff needs older software working on the computer to work, the newer drivers for some reason aren’t recognizing it.

If you installws WD Discovery from Western Digital Product Software Downloads which will point you to
and it still doesn’t work…

I needed something very old from an older system. It’s called WD Windows Tools, and looks like it was designed for Windows Vista, but it seemed to help because it’s working now. (It is also known as MyBook Premium). which leads to

These are legitimate softwares from WesternDigital. I just don’t know if Windows 11 will block it from installing - it worked on Windows 10 just now, though.