Windows XP Pro PC tries to boot off MyBook 1TB drive


#1

I have to power down the MyBook external drive before booting the PC, otherwise the PC attempts to boot from the MyBook.  I’m running Windows XP Pro.  I’ve already turned off the option to boot from USB device in the PC setup.


#2

What you need to do (in addition to disabling USB boot) is to enter the BIOS and actually look at the hard drive boot order.

There should be a section that lists just the hard drives only and in what order the system looks for an MBR. Either remove the MyBook from the list or (in most cases you can’t remove entries from this group) move the MyBook to the very bottom of the list so it looks to your Internal disk first and finds an MBR on it before it gets to the MyBook. Once the system finds an MBR on a disk, it will load it and not look further for one (ie, the MyBook)

If you do that, you can safely re-enable USB booting for future use with flash drives, USB optical drives, etc.


#3

Thanks whatisname, but I’ve tried that.  I’ve tried disabling booting from USB devices, but whether this is enabled or disabled, it will not boot when the MyBook is powered on.  Strangely, it won’t even let me enter the BIOS!  So, without the MyBook connected, I can boot sucessfully, or I can interrupt the boot process and enter the BIOS.  I can’t change the boot order of the MyBook because, of course, it doesn’t appear (seeing as the only way I can enter the BIOS is when the darn thing is disconnected).  However, I expected disabling the boot from USB option would solve it.  Whether boot from USB is set to enabled or disabled, when I power up with the MyBook connected, it just hangs (ironically, at the screen at which I would normally enter the BIOS).  Only way to move forward from here is to hold the PC power button in for 8 seconds and force the power off.


#4

Unfortunately, I know exactly what you mean now that it’s explained a bit clearer. I have had the same issue you describe minus the booting the wrong HDD. The fact that it’s searching the MyBook for an MBR is a sure sign that the hard drive order is set with the MyBook on top of the internal HDD. - The ONLY way to change that is to enter the bios and lower the MyBook in the hard drive list. (USB booting isn’t going to matter on some newish systems as the MyBook may be detected as a hard drive to the BIOS, not necessarily a USB one which is why USB booting option is not effective. If you can’t enter the BIOS because the MyBook causes your POST to hang, then you’re really stuck. You’ll have to keep the drive powered off until POST completes. That’s no solution is it?

On my Lenovo Netbook, the powered on MyBook causes the same hang at BIOS. It actually appears to hang but doesn’t… it just takes one heck of a long time to complete POST/enter Setup with the drive connected(Bet its a similiar problem with the EHD’s design and Windows 7 booting), but if I wait it out, I can eventually enter the BIOS(or complete POST)

The bottom line is I really feel the Essential-line of drives were made very poorly - mainly their “Galaxy” interface board. Heck, there are even typos in the EHD’s hardware ID in Windows! To me, that speaks of it’s quality.

I’ve got nothing but WD Internal drives in my systems and always had nothing but success with them but I’ve had a bunch of headaches with my MyBook - so much so that I probably won’t be looking to WD for anymore external drive purchases.

Sorry I don’t have a proper solution, it’s always been hit-or-miss for me and my MB Essential and I know I’m not the only one with these “issues”.

The bottom line is, some systems have no trouble with the MyBook connected and powered and some do. I have been lucky enough to find out two of my six systems hang at BIOS with it connected and all of the Windows 7 computers won’t boot (Windows) correctly with it connected.

Good luck


#5

Many thanks for your thorough explanation.  At least I don’t need to waste more time trying to find a solution.  I will live with it and buy a different brand next time.  Regards.


#6

Hi everyone

I have similiar problems and I seem not the only one with experiencing this. Unfortunately the MyBook does not appear in the boot order list in BIOS, however it appears as a hard drive in the menu that says hardware configuration. I cannot turn off USB legacy as suggested in other forums.

My idea is to solve the problem by creating a MBR on the drive and some sort of boot manager which then boots from the internal hard disk of my computer. Has anyone an idea what would be the software of choice?

Thanks

Phil