Windows XP: My Passport Essential Terabyte: Driver not installing on laptop


#1

I have a Dell Latitude D630 running Windows XP Professional.  I purchased the WD My Passport Essentials 1 TB.

http://www.wdc.com/en/products/Products.asp?DriveID=722

I plugged it into my laptop and the driver is installed as “My Passport 070A” with a Yellow exclamation point.  I am usually capable of solving any computer problem i have and everyone elses, but this one i’m at a loss.

I have plugged the drive into my desktop PC and it works perfectly fine.  It installs the SCS SES drivers and works as intended.  I was on the phone with WD customer support for an hour last week and they said i needed a more powered USB cable.  So i got it this week while i was out of town and tried it out.  Same error.

I have copied the contents of the drivers from my desktop PC as well as the software for installation.  When i go to update the driver from the device manager, and select the drivers contained in the Extra directory, it says the driver is not listed in this location.  I have also copied the contents of the drivers directory into my C:\windows\system32\drivers directory.

I still get nothing but the yellow ! on my device manager from my laptop.

Suggestions?

Thanks,

Kevin


#2

This may not be of any help, but with the D620 the USB is adjustable in setup.  On mine, I had to switch the USB ports from 1.1 to 2.0.  The default setting on the D620 is 1.1.  I don’t know if the same applies to the D630.  Just a thought…


#3

Is that a bios setting?  I didn’t see the option when clicking through all the entries in the device manager for the Universal Serial Bus controllers.

Thanks,

Kevin


#4

Sorry 'bout that…yes, it’s a bios setting.  F2 on the boot screen.


#5

I went through the bios screens and could not find anything other than the enable/disable options.  There was no setting that says USB 2 only.  Kinda like how you can set your wireless card to only pick up a specific A or B or G setting.  Wasn’t able to find anything.

-Kevin


#6

I figured it a long shot.  The D630 is different in most ways from its predecessor.  Anyway, when setting up a WD ext drive on my D620, I discovered the USB port speed can be switched from low to high.  In the end, I formatted the drive and loaded a third party backup software.  Works good for me now.

Good luck with yours. 

Steve