Windows XP freezes with a blank screen when I connect My Passport Essential SE 1TB


#1

Hi, hope you can help :slight_smile:

I’ve got an Asus eeepc Seashell with XP OS, and I recently bought a My Passport Essential SE 1TB (this one has only one cable for power and connection). When I connect the 1TB it recognizes the device then the whole sreen goes blank and I can’t get out of it. ESC doesnt work, can’t open task manager and I need to restart my netbook :(. As there is only one cable for the 1TB, I tried connecting it through with my usb hub which has a connection powered through the wall, so it does have ample power.

I have tried it on my sisters and dad’s laptop’s (both Vista’s) as well as the home desktop PC which is also an XP OS. The 1TB passport works on all of these…but not mine! I have tried a smaller (250GB and 500GB) external hard drive and they work fine, but this 1TB is not working :frowning: is it because its 1TB?

I have contacted WD and the telephone support people said it’s not their fault, and that I should contact Asus, however as it is still under warranty they can give me a replacement one, (because the one I have now might be faulty, they said. But it works on every other computer I have). Anyway I call up Asus and they have no idea and say that I need to install this “Advanced Format Hard Drive Download Utility” which I did but does nothing!

Someone please help, because I really like my netbook and this 1TB but why can’t I have them together???


#2

When you tried it on the USB hub, was the hub connected to the Eeepc?  If so, is the USB hub powered?  The simple answer is that the Eeepc may not be putting out enough power to drive the 1 TB Passport straight from the USB port.  You may need a power booster cable from WD for it to work.