Windows Explorer, WD My Cloud app cannot detect WD My Cloud on my home network even though Network Discovery is enabled

It used to detect my WD My Cloud, but now it won’t detect it anymore, can still connect to the IP on browser, I tried reseting the my cloud to factory settings but still no help

Have you rebooted your router? What operating system are you using?

You can use the IP address in Windows File Explorer. For example: \\

Couple of things to check. Ensure the My Cloud is using the same workgroup name as the computer and other devices on the local network. Make sure the My Cloud is in the same address range as the rest of the other devices on the local network. It is generally advisable to reserve an IP address for the My Cloud within the router so the My Cloud uses the same IP address each time it is turned on. One can perform an internet search for their router model to find out directions on how to reserve an IP address using the router’s administration page.

Windows cannot access the IP address although I typed it correctly