Windows Explorer Keeps Stopping and Re-starting after using My Cloud

I’ve recently purchased and installed a WD MyCloud Mirror 2TB NAS to my system.  The My Cloud desktop application seems to work OK until I exit the program.  After that, I get a continuing error saying “windows explorer has stopped working” followed by “windows explorer has re-started”.  This continues until I reboot the PC.  I’ve tried uninstalling and re-installing all related software and I’ve also found some other threads on this board relating to the same issue, but nothing I can come up with fixes it.  Any ideas?

My 2 cents here.

I have Vista Home Premim on my PC. Initially, no problem till some years later where I started to have occasionally Win Explorer crashing and restarting. Checked on the web and there were many people having the same problem. One guru suggested to disable the DEP but I did not do that as that would disable the OS security.

Learnt one thing from my My Cloud installation. I was happy that I managed to install My Cloud till I was about to call it a night. Could not log into My Cloud as admin or any of the users. Gee … Later I noted that I could log in via Desktop apps if I clicked on the folder in the main page (not the folder on the left vertical window). 

Next day, I tried the same methodology (using the folder in the main page and not the vertical left window), surprise, no more win explorer crashing! Ha.

This does not solve the problem but it helps me in minimising the annoying win explorer crashing!.