Windows - Delayed Write Failed


#1

My computer is not recognizing files on my WD external drive. The drive is about 1/2 full.   It will see some folders, but not always files within the folders.  The blue rings are constantly going around.

My screen saver images come from a folder from the WD drive. When the computer goes into standby now, there is a black screen stating that there are no photos in that folder.

This is the error I am getting:

"Windows - Delayed Write Failed

Windows was unable to save all the fdata for the file K:$Mft.  The data has been lost.  This error may be caused by a failure of your computer hardware or network connection.  Pelase try to save this file elsewhere."

I’ve not asked the drive or my computer to save anything.  I’ve restarted both computer and hard drive.  Problem remains.  I am running a virus scan now.

Has anyone had this happen? Is there any hope of recovery?

My kids lives are  documented (or were) on that drive!


#2

I have the same problem did you get any info looks like i also lost pictures. 


#3

Yes … VERY FRUSTRATING and I can’t understand why Western Digital doesn’t provide help on it’s support site … because we’re not the only ones. I have been looking for help and just found this article, but have not tried the solution yet. But, check this out … DWF - Solved

If you or anyone else has anything else to offer on this, please post! And I’ll post if I get something to work.


#4

Try changing the cable.  sometimes it just that simple.  if this is a network drive, try accessing it from another pc and see if that helps.  or if it’s an external drive, try connecting it to another port as well as trying another cable, and try another pc as also.  you could also make sure the drive is getting enough power by plugging it directly into the wall outlet. 


#5

i’ve been having this problem for almost 2 years now

i’ve looked all over for a solution

and found none

is WD even looking at these threads and trying to come up with some type of solution ?

i’ have been able to get it to work a few times, and at those times i’d pull files from off of it, then it would just give me that same write fail error message after a while


#6

can it also be caused by some of the files placed on the drive ?

like files with long path names

sometimes when i turn it on the autoplay box shows up and starts to go through the files but then stops and gives me the write error message

perhaps there is a file on the drive that causes it to stop due to the drive not being able to read it ?

another thing i noticed is that it works fine (for me) when windows xp is installed fresh

maybe the updates and hotfixes contributes to the problem

doesn’t WD have experts somewhere that can fix this highly annoying problem ?

i mean like dam, it’s been close to 2 years now and no solution

i feel cheated