Windows 7 not seeing WD My Book 3TB

wd.jpg

Same problem as many others here.  Not seen or accessible in explorer, but computer sees it in device/printers and

Disk Management.  It does not seem to have a Drive letter associated with it.  When I try to change that, I get the

error shown.  I have tried many of the suggestions, nothing working.

I also took the drive setup to another computer ( Windows Vista ) and it discovers fine.  So that would eliminate a bad cable

or drive corruption as I could connect and browse these items from the other computer. 

Joemt.

Try a different port on the problem computer. Also don’t connect through a hub or use a cable longer than the original. Also try plugging power directly to the wall instead of a surge protyector. Make sure your USB drivers are all up to date.

Joe

I have 10 USB ports in total, 4 USB3, 6 USB2, it is the same either type using the OEM cable.  I have 2 other WD drives and tried those cables as well.  Do you have anything deeper?  As stated, I’ve tried all the purposed solutions without any success. 

Joemt.

The Windows system you are using only recognizes up to 2 TB.  The System is using the old MS Dos based system.

MBR (Master Boot Record) and GPT (GUID Partition Table) are two different ways of storing the partitioning information on a drive. This information includes where partitions start and begin, so your operating system knows which sectors belong to each partition and which partition is bootable. This is why you have to choose MBR or GPT before creating partitions on a drive.

Now You cannot use the Disk Management system from your computer, if you are not given the option to choose which type of disk you wish to create when you first attach to a computer.

The Disk Management program will not list as below.

  • After you install a new raw disk, open the Disk Management console to start a wizard that you can use to configure the new disk. The wizard includes options to initialize the disk as MBR or GPT.

Now you wish to choose GPT, BUT, this does not occur.  I have a Laptop, which I connected the MyBook 3 TB to, and low n behold, immediately a Window pops up, and advised, if I wish to use the harddrive, I must choose which format I wish to use, and format and partition as required.  So I choose GPT and format, now I connect to my computer and shows full 3 TB.

I would suggest you find a friend with a laptop, with Windows 7 to Windows 10 and connect your unformatted unpartitioned MyBook 3 TB to the laptop, and you will be able to format to 3 TB…

Thanks for the info, I was not aware of that.  My pc has windows 7 home premium 64 bit.

Would that not be sufficient to prompt me if it were working correctly?  I ran a diskpart

and cleaned the WD 3T drive, choose to format in GPT, selecting 1.5 TB partition and

1.5 unallocated.  It times out with the same errors as before.

“The operation failed to complete because the Disk Management console view is not up-to-date. Refresh the view by using the refresh task. If the problem persists close the Disk Management console, then restart Disk Management or restart the computer.”

I must say, I’ve had some hard drive issues prior to this.  I’ve run chkdsk and scannow

multiple times.  Chkdsk was finally clean, however scannow reported some windows files

maybe corrupt and could not be fixed. 

I’m wondering if I should just use the recovery disks created at purchase and start over.