Windows 7 not detecting my hard drive

Hi,
my 80GB WD Passport is not being detected by my laptop when plugged in (by USB). A LED at the side of the external hard drive indicates that it is being powered on even though the computer shows no sign of detection (no sound indication; nothing showing up in My Computer). May someone please assist me in solving this problem? Thanks a bunch.

External Hard Drive Specs

80GB Wd Passport, model wd1200u017-002.

It is only compatible with USB 2.0.
(please note that my WD Passport is very old)

Computer Specs
Windows edition: Windows 7 Home Premium
Manufacturer: Dell
Model: N5110
Processor: Intel® Core™ i3-2310M CPU2.10GHz 2.10 GHz
Installed memory (RAM): 6.00 GB
System type: 64-bit Operating System
(note this computer has both USB 2.0 and 3.0 ports, tried the harddrive in)

(guys, formatting the WD Passport is not an option as the drive contains important files.)

The drive is not compatible with Win 7

try using on XP or Vista

1 Like

I tried on Windows XP, and it doesn’t work there too.

Another thing I’ve noticed is that the WD Passport would make a repeated clicking noise. Just saying if that is any help.

Nevertheless, thanks for replying.

Is there no one else willing to help? Please, there are irriplacable files in that external hard drive. Thanks again.

Try This

Steps:

  1. Explorer - right click on Computer - Manage

  2. Disk Management in left window

  3. In lower portion of middle window find your external drive (maybe Disk 1). Try disconnecting and reconnecting USB cable to identify if having difficulties

  4. Right click inside a white rectangular block - Change Drive Letter

  5. Assign a different letter (ex: P) Should be visible in the Explorer as new letter drive.

Good luck.

1 Like

Hi, thanks for the reply :slight_smile:

When I went to Disk Management I couldn’t find my WD Passport in the lower portion. All shown was Disk 0 and CD-ROM 0. I tried reconnecting it, but unfortuanately there was no response. Thanks again for replying though…

Is there any other help?

I am Facing similar prob… How did you got it solved… Reply appreciated 

Thanks in advance