Windows 7 does not see MyBook Home 1.5TB but the BIOS does


#1

I am struggling to get this device seen by Windows 7.  All my BIOS settings are up to date and the BIOS actually sees the drive on boot because it displays this information.  Windows 7 starts and nothing ever appears.  This seems to be an ongoing issue with WD eSata connections, although I have one of these drives attached to my Mac Pro and it works fine.

I have looked on the support page for updated files but nothing appears.

Has anyone got one of these drives working properly under Windows 7 connecting from the eSata port on the motherboard to the drive?  I know that USB2 works and that FireWire 400 works but I bought the d*** thing for eSata connectivity.

Thanks,

Doc


#2

My 1.5 TB MyBook frustrated me under Windows 7, eSATA,  (but worked under Windows XP w/eSATA, and Windows 7 w/Firewire) until I upgraded the firmware to 1.034. After tje firmware upgrade, MyBook has been stable under Windows 7 w/eSATA. Don’t assume that your drive has that January 09 update simply because it came w/ August 09 software. I purchased my drive from Best Buy in November 09, and the drive included August 09 software, but the firmware was still the 1.028 version.  You can view the firmware of your MyBook by checking its properties in Windows 7’s device manager applet (Start>run> type in “device manager” in the search box and select the program that Windows 7 finds). Somewhere in the drive’s properties, you’ll see the name “MyBook” followed by a string of letters, numbers, and other characters. I’m not near my PC right now, but that string will include something like “1028” or “1_028” if you have the 1.028 firmware and “1034” or “1_034” if you have the 1.034 firmware.

You can download the 1.034 firmware at http://support.wdc.com/product/download.asp?groupid=111&sid=99&lang=en.  Make sure to follow the instructions on that page. I had problems running the update until I closed several background programs and reran the update program.  EndItAll 2, free software available at http://www.docsdownloads.com/Tier1/enditall.htm provides a fast, simple method of closing background programs.  Before running EndItAll 2, manually close any background programs that include “exit” or “close” commands in their interface.  Then, when using EndItAll 2, select “Close Programs” rather then “Kill Programs” to minimize potential stability issues.

Once last point.  Western Digital’s Drive Manager does not function w/eSATA. The capacity meter that Drive Manager provides is nice, but not essential, and I wouldn’t give up the added speed of eSATA for that function.


#3

My windows 7 (64 home premium) does see my MyBooK Home 500G,  which is running on the old firmware, on esata, but I’d like to upgrade to the new firmware.  I am constantly getting the message: "error loading generic library. ".  I have tried running in emulation mode, but it makes no difference.  I have tried using enditall,  but still get the same message.

Any ideas? 

thanks.


#4

I’m not sure if this is your problem, but when you are upgrading firmware, the MyBook must be connected to your PC via USB rather than eSATA or firewire.

You might also trying running the firmware update as an administrator. Right-click on the update program and choose “Run as administrator.”


#5

Hello,

I have the same problem, but when trying to update the firmware I get the message: “Error while loading generic library.”

I’ve connected the MyBook Home via USB and use Windows 7 64bit as OS. The firmware for my book is V1.034

Has anyone a solution for this issue? I tried to reach WD via email but didn’t get any answer.


#6

I do not know if this helps but: I had a problem with WD MyBook Studio II and WIndows 7 (64bit). (Previously a bit similar problems with Vista 64.) USB works pretty fine (though it did not always recognize plugging/unplugging) but I did not got eSATA to work at all. This is, the disk was not recognized at all. The solution was: Goto Power Options-> Change Power Plan Settings -> Change Advanced Power Settings -->

  • Hard Disk --> Turh Off Hard Disk after -> on battery and plugged in: <-- NEVER.
  • USB: Selective Suspend Setting-> on battery and plugged in: <-- NEVER

And after that eSATA works perfectly! Hope that this helps you…