Windows 7 Does not detect in "Computer" but is seen in "Disk Management"

Okay so here’s my problem. 

I have a 2 TB My Book Essential. For a year it’s been working wonderfully, it’s fast and it was able to hold all of my files and what not. 

Yesterday, it was working perfectly fine. I was even watching a movie I had download on it earlier while it was still connected to my laptop via USB. Then I needed to move a few music files from my external onto a USB. It was working fine for about a minute, then it started to lag and windows said that it was unresponsive. Thinking that it just needed to be closed and then opened up again, I simply opened closed Windows Explorer and then it gave me “Unresponsive Message”. It started lagging my entire laptop so I began to close everything, thinking that my laptop just needed to be restarted. Then I just went into “Task Manager” and closed the file then went to restart my laptop. 

I boot up my laptop and then everything seems to be working fine. I then look into my “Computer” and it didn’t appear. 

However, it was present in “Devices and Printers” where I can eject it. I thought that maybe it was a USB issue or something. 

I’ve tried uninstalling and reinstalling the drivers (twice, one two different laptops). I’ve tried unplugging and plugging in the power. I’ve tried it on three different laptops (all windows 7, will try a Vista computer later tonight) all of which can not detect it in the “Computer” but see it in “Devices and Printers”.

Then, I decided to look in “Disk Management” where in which it says it’s there, but it has no drive assigned to it. Nor can I assign it to a drive. When it first pops up, I get a message saying I need to intiliaze it. Then, when I click disk 1 (the HD) and then click a way to intialize, for both options it shows up a message almost instantly that says “Media Write Protected” which doesn’t make sense to me because I never used the password function. It says it is “unallocated” and the bar is black (as opposed to the blue of my USB and my laptop’s own harddrive) and the only option I can do with it is “Initiliaze” and properties. The “new volume” buttons and what not are not able for me to highlight. 

The harddrive still makes a spinning noise when I first plug it in, and it sounds like it works fine. So I don’t think it’s a physical issue. Especially since it is detected in “Devices and Printers”. 

So I went online and saw that other people had this problem too. 

I’ve tried recovery programs like Recuva that can’t detect this external at all, Stellar can’t seem to detect it either, I’ve tried the WB format program which says it can’t format this harddrive, I’ve tried to recover it with TestDisk too but that just lead to a message saying “Partition Read Error”. 

I seriously need the files on that HD (it has a bunch of papers and stuff on there that I need ASAP) and obviously, since I’m here, I can’t afford to go and get it recovered. >.> So does anyone have any solutions as to why this is happening? And why I can’t even format the HD? 

Thanks for any help! 

You should have waited for the drive to response. You forced to stop the transfer using task manager, that’s why the data inside the drive was corrupted. Also when that happened, is your laptop running on battery or is it plug in using the power adapter? You might want to check this link if you want to recover your files, . And please DO NOT ATTEMPT TO REFORMAT YOUR DRIVE, so that there would still be a chance for you to recover the files inside the drive if your going to a data recovery center.

Ah dang, that’s what my sister just told me too. >.> 

It was plugged into the adapter. 

So this may be a dumb question, but the external can’t be saved right? Because it’s corrupted. When I go, I’d have to get a new one when I go to recover my data (I have roughly 500 GB on it that were used and sadly, my hard drive on my laptop isn’t nearly that large). 

Thanks for your help!

Try to check the link, maybe it will help you.