Windows 2012 Server non compatibility workaround

Hi all - purchased my EX4 this past weekend and much to my dismay there was no way round for me to get my home media server running 2012 to backup to my EX4 using Smartware or Windows Backup Services.

Smartware cannot see the EX4 - just lists Dropbox as an optional location for backups

Windows Backup Services - job creates fine but fails when I try to backup a test directory and mp4 file

My next step was to look into iSCSI which seemed like an ideal alternative… but with the options within the EX4 settings to only allow round number TB’s for the iSCSI disk reduced my just 5.98TB RAID1 (2 x 6TB WD Red) to a 5TB iSCSI drive… I wasn’t happy with this

So I decided to go back to basics and go with a batch file and the xcopy command - the following command line run in a batch file by Windows scheduling services copied all of the data off my server into the Backup directory I had setup on my EX4 - huzzah!!

@ECHO OFF
XCOPY *original location* \*EX4 Name*\*backups directory* /m /e /y

So a working XCOP command may look like mine :-

XCOPY F:\ \EX4\backups /m /e /y

Here’s a link for those that may need a little help with the creation of batch files

http://www.wikihow.com/Write-a-Batch-File

Hope this helps anyone who’s struggling with this

1 Like

Thank you very much for sharing. A great community is composed of shared knowledge addressing every need.

Regards,

mrwips wrote:

 

My next step was to look into iSCSI which seemed like an ideal alternative… but with the options within the EX4 settings to only allow round number TB’s for the iSCSI disk…

 

Actually you are not allowed only round number TBs for iSCSI disk. You can have an iSCSI disk of say 0.5 TB (512 GB) capacity. You just need to change the unit of the drive capacity using the dropdown from TB to GB and calculate how many gigs you need and use that number accordingly - so to create a 0.5TB iSCSI drive, just enter 512 GB.

Great shout - I should have thought a little more around it

I might give that a go and try  using Windows Backup Services onto an iSCSI disk then.

Also spotted an issue with xcopy in that if a file name and path location are too long it won’t run the command - so it obviously runs some path length checks into the new location

mrwips wrote:

 

Also spotted an issue with xcopy in that if a file name and path location are too long it won’t run the command - so it obviously runs some path length checks into the new location

This is a known issue with xcopy…see ->  http://en.wikipedia.org/wiki/XCOPY#Limitation

Try Robocopy.

If my answer helps you resolve your issue or at least sends you on the path to a solution, please click the star on the left under my username to give me a kudo.