Windows 10 Can't Open WD Elements

My computer recognizes the drive as plugged in, but can’t open it. I just get this error message “Location is not available. F:\ is not accessible. The parameter is incorrect.” or “Location is not available. F:\ is not accessible. The request is not supported.” The drive is bootable from Macs, Windows 7 on a different computer, and my Samsung TV. All the data is still there and uncorrupted. It used to work on my computer (Dell XPS 13). I don’t know a list of things I’ve changed on my computer since it last worked but everything else is functional.

Troubleshooting: I’ve uninstalled and reinstalled the drive. I’ve checked for updated drivers through Windows like WD recommends. All is up to date according to them.

WD Drive: WDBU6Y0020BBK
PC: OS Build 14393.105 (newest version)

Hi, does this happens in all USB ports? Have you tried changing the cable?

It happens in every USB port on my PC. I don’t have an additional cable, but that cable works on the other devices listed above.