Window XP an WD ex2 ultra


Windows XP all availlable Patches intalled (yes i know, do not get mad about XP )
EaseUs Todo Backupper free version latest vers (13.0)

Nas WD My Cloud ex2 ultra
Only one User Named: admin
We have set the password and are able to login to the setup panel of the device
We have made a share which is accessible from Windows XP (mapped share drive letter N)

Now I try to creat a backup task using easeus todo Backup I click on target and select NAS device and add NAS device
I specify the IP adress which is correct since I can login to the web interface
using this IP addres.

What ever I try, it results in “incorrect user or incorrect password”

Variant 1 user: admin
pw : our known password
anonymous: not checked
Result: fails “incorrect user or incorrect password”

Variant 2 no user
no passwort
anonimous checked
Result: fails “incorrect user or incorrect password”

inside the same network I am able to connect to the NAS with a W10 PC.

How does my WD My Cloud ex2 ultra have to be set up to handle Windows XP Requests?

Tank you
Mung gee

It should be noted that if you are running OS5 (v5.x) firmware on the My Cloud EX2 Ultra, WD indicates ( that the Requirements are Windows 8.1 and Windows 10, not Windows XP.

If one is using OS3 (v2.x) Firmware then the Requirments are: Windows Visa, Windows 7, Windows 8 or 8.1 and Windows 10.

While Windows 7 should work its possible some applications may have problems accessing an NAS like the My Cloud.

One may have to use something like \\ in the address field in the EaseUS program. Or one may have to specify the IP + the Share name. Example: \\\Public.

One should also check the settings of the Share in the My Cloud Dashboard to see what it’s settings are. One may have to set the Share to Public (On) rather than Public (Off) and see if EaseUS will see and back up to it. And as a troubleshooting step, one could always enable NFS on the Share and see if the Share is accessible by the EaseUS program.

Go to Settings → Network → SMB Protocol and change the SMB version to “SMB 2, SMB 3”.