Window 7 can't find My Book Live 2TB

Hi guys. the light infront is green (no blink) and all the light seems fine but when I put in the CD it wasnt able to find my drive. anyone ever have such problem? thx!

there was a problem when you have security eesntials installed on your machine

Just typ in the Ip adress in the browser and look if its avaible.

Then you can mount it as a networkshare.

And take a look at your firewall.

Microsoft’s Security Essentials should not get in the way. It does not get in the way on my set-up. You don’t actually need the CD if you don’t wish to use SmartWare’s back-up facilities. I didn’t use it.

What might help is to install Smartware as this installs Apple’s Bonjour mDNS client.  If you don’t wish to install Smartware then install the Bonjour Print Services for Windows ( ).  Once you’ve done that then instead of addressing the drive as MyBookLive address it as MyBookLive.local.  ( http://MyBookLive.local )

See how that works.

I have exactly the same error, something to do with windows 7 not being able to resolve the name so wdbooklive or whatever it’s called cannot be seen it give a 0x80070035 (?) error if you try to network the drive.  It can be seen via it’s IP if you type this into explorer.  However this takes me to the dashboard not the folders…

Someone suggested that you use the same name and password for the WD user as they have in windows, this didn’t work for me. 

Open the command prompt, issue the command **NET USE** and post the results here, if there are any results.

Thx for your reply guys!

Myron, I’ve tried your method to download Bonjour print services for Windows then go to Mybooklive.local but on the website it say ‘The network link is down or has become intermittent. Please check your network connection.’… so it still couldn’t detect my HDD.

I also tried download Smartware from WD website but it also couldn’t detect my HDD…

I’m using ESET smart security anti virus/firewall, do you think is possible that it block my pc from detecting the HDD? I’ve tried to look into the anti virus but I’ve no clue how to unblock it… thanx a lot for your help!