Win10 doesn't see mycloud

#1

my up-to-date win10 pc doesn’t see my mycloud. 2 macbooks see it. i can log in to the admin account from the pc, but can’t access it for use. the newest discussion i can find here is from 2015. i certainly could be missing the relevant posts on the issue. i have tried almost every workaround from the older discussion with no success. thanks for any help.

#2

How long have you had your My Cloud and what troubleshooting steps have you tried so far?

#3

What, this one?

How are you trying to access? File Explorer? Mapping drives? WD App?

#4

thanks for replying. i have read the instructions. i have created a user account for a macbook and used it to back up with time machine to mycloud. i am redoing each of the suggested workarounds for connecting a win 10 pc to make sure i made no mistakes.

#5

thanks for replying. have had mycloud for 2 weeks. have successfully created user account for my macbook and used it to backup with time machine. i am redoing all the suggested workarounds in case i made an error.

#6

Is your My Cloud in the same workgroup as your Windows 10 computer? See image below.

Click on, tap or activate image to enlarge it.

Do you have Network Discovery turned on in the Control Panel?

1 Like
#7

retried all workarounds except 6. none worked. turnd off pc. let it rest for several days. turned it back on and mycloud appeared in network, but not in this pc. i can access mycloud thru the downloaded program “WD My Cloud.” mycloud does not show up as a local drive. when i click on MYCLOUD in network i get “can’t find \WDMYCLOUD” (all caps). when i try wdsmartware backup i get a screen showing the pc harddrive as source and WD MyCloud as target. i select both. then nothing happens. so… i have advanced some, but apparently not quite all the way

#8

i uninstalled zonealarm and now my pc connects with mycloud and wdsmartware is backing the pc. thanks to all who offered suggestion.