Win XP network share makin me crazy!


#1

I just replaced my wireless router with a new Linksys E3000 router and can no longer see my PC with WinXP in the network share. I have a DLink N USB adapter on the WDTV with 3 computers on my network, 2 macs and the PC. Previously I had been using a Linksys W54G router and was able to see all the computers on the network share in WDTV but now all I see is the 2 macs- the PC will not show up no matter what I do! Curiously the router itself is showing up in the network share!? I can share the files on the PC with all the other Macs over the network but not in WDTV. I also use PlayOn which is working fine and that is on the PC so I’m baffled. Thank you for your help!


#2

any help?


#3

I forget how XP works (because I’m all Vista and 7 now) but, when you changed the router, did your XP box create or assign a different network profile?

In Win 7 land, I changed my router a month ago (same make and model even) and my Win 7 box assumed that I was on a NEW network, and marked it as “Public.”   The public profile DISABLES Network Discovery and activates other things like the firewall.   It took me about 4 hours to figure out that had happened, and once I went and change the profile for the interface back to “Home Network,” all was restored.

Check it out and let me know!


#4

Hey thanks! I want to try this but where exactly do I change the profile for the interface? I went to settings and tried users and network but could not find what I think you are talking about. Is this one of the router settings? Or perhaps since my firewall is activated that is causing the problem. I don’t see WDTV listed as an exception. Thanks in advance!


#5

Sorry, don’t really have a way to look deeper.  The only XP box I have access to is my work laptop, and it’s all locked down with administrative policies, so I can’t examine a lot of stuff… 

Hopefully an XP expert will jump in.


#6

Well, I have plenty of XP boxes but I have zero idea what Tony’s talking about.

Accessing the router via XP is exactly the same as accessing it via Win 7 – it just runs a browser interface that controls router settings.  So I’m not sure what I could even tell you.

XP shares aren’t rocket science – they operate the same way as Win 7 for the most part (indeed, Win 7 shares are more restrictive).  So I’d examine all the usual suspects – make sure your XP box workgroup is “WORKGROUP”, make sure you’ve got passwords OFF on the net shares, make sure they are shared with everyone, etc.


#7

Not that it’ll help, but this is what I see on Win7 / Vista:

It identifies me as being on my Home Network right now.  (See how it thinks its NET 4?  That’s because any significant change will create a new profile.   I’m on my 4th go in 5 months.)

The policies differ based on that profile:

I can’t remember if XP has any similar logic.


#8

There’s no equivilent in XP – “network discovery” is always on (all of that complexity was added in Vista, and it’s not all helpful).  A share is a share is a share – you either share a directory or you don’t (and if you’re all on the same workgroup, you’ll all see it, plain and simple).

So, as I said, all you need do is make sure you’ve got the workgroup as “WORKGROUP”, the passwords for the shares turned off, and the shares set to everyone (and the last isn’t even necessary, AFAIK – can’t remember offhand if it’s even possible in XP).  XP is a *whole* lot simpler than Vista/7.


#9

Perhaps…  Once indoctrinated, though, I’m lovin’ 7 compared to XP *AND* Vista. :) 

By the way, yes, the E3000 will show up as a network sharing server even if you don’t want it to. 

You can plug a USB drive into the E3000 and turn it into a NAS, and it’s also a DLNA Media Server.

I use neither of these functions, and I filed a feature request with Cisco to have that option optionally DISABLED.

Really, it shouldn’t show up as a share if there’s nothing attached TO share… 

ODearDave, I just thought of something:   How do you have the E3000 configured?   Are you using the Web GUI, or the Windows Software utility?

The two are mutually exclusive.  The Windows Client can set up an isolated network that prevents certain Wireless clients from accessing services on your local LAN.  It’s based on SSID.  Is there any chance you did this?

Do you have AP Isolation enabled?  (It’s under Wireless / Advanced Wireless Settings tabs in the WEB MANAGER ONLY.) 


#10

Not to get too OT, but I like Win 7 enough (not *love* it – it doesn’t really do anything I can’t do in XP and some things are still VERY peculiar and unnecessarily complicated).  One thing for absolute sure – my XP machines are much leaner in every respect.

I skipped Vista so have no opinion one way or another.


#11

"Do you have AP Isolation enabled?  (It’s under Wireless / Advanced Wireless Settings tabs in the WEB MANAGER ONLY.) "

Had it disabled and guess what happened when I enabled it? Everything works now!!! I don’t know what AP Isolation is but whatever it is I think I like it.

I never did use the CD that came with the router, I just used the web interface. I was getting ready to reset the router and use the cisco connect program but you have saved me the trouble- THANK YOU!!

I like this router. I think it has a better range than the d-link DIR-655 that I got and returned. But that thing with it showing up on the network is annoying- even if the UPnP media server is disabled. That just added to my complete confusion. Thank you again!


#12

Oh, boy.   Now I’m worried. 

I’m glad you’re up and running, but from what I understand, that shouldn’t have happened.

What I get is that, if you ENABLE Wireless Isolation, then wireless devices can NOT see any OTHER wireless devices.

If you DISABLE it (which is the default) then Wireless devices can see each other.

Since you said that you were able to see your PLAYON Server on the same computer, that now indicates that there was a path.  I’d about bet that if you went and DISABLED it again, you’d still be working.  But hey, I’m glad we got ya working.

Please use the SOLVED function.  :)


#13

Tony, you solve stuff without hardly even trying .

I’m going to give you a kudos (although for the life of me I can’t quite figure out why :>)


#14

Now I’M worried. You solved my problem and you’re not sure why! But I find that my shares have always been flakey, even before I switched routers. Sometimes it would take them awhile to show up. Everything indicated that the PC should have showed up as a share- but it did not. Even stranger: I turned on another PC (old with Win2000) so Now I had 2- PCs and 2- Macs wired to the router. Before I enabled AP isolation only the Macs would show- none of the PCs. Why??? The only common thing I noticed was that according to the lights on the router the two PCs are only on 10/100 ports and the 2 macs are on gigabit ports. The important thing is that it is working for now, knock on wood. Thank you again!