WIFI wireless adapter issue


#1

After reviewing the list of approved or on the list of adapters I bought the D-Link wireless N 150 USB adapter (DWA-125), I connected it to the WD TV Live Plus device and went through the network settings and I found my SSID (auto & manual) and tried to enter my password.

My password is all in caps on my Cisco wireless router (also on the approved or tested list) I noticed the menu on the WD TV Live Plus for entering the password only allows for lower case letters. Is this an issue. My wireless adapter sees all wireless devices around me and I select my SSID and the password comes up, but like I said, when I enter my password it doesn’t work. No IP address found.

I’m running a simple setup here, have an external USB hard drive connected with all my movies, music and photos and all works great. Just can’t connect to the internet.

I also have not updated the firmware because of some of the reviews on this site. Is there some firmware updates that address this issue with maybe the upper / lower password issue.

Can anybody help.


#2

You can change to CAPS by pressing the “shift” button which is labelled 

ABC

(as opposed to abc)

That will shift the keyboard to capital letters.


#3

That worked! Thanks