Wifi Problems with the latest firmware

I’m a loyal customer and big fan of the N900 Central.  Up to now, despite the issues, its been a good router and has been doing its job well in my network.  

After the last firmware update that changed.  Now none of my macbooks can keep a connection to either the 2.5ofghz or 5ghz network.  Based on the logs I know that my iphone is having similar problems but can reconnect quick enough for it not to be noticable.  Its asking for a new DCHP request every 30 seconds to accomplish this.  

I’ve tried:

-Changing channels

-toggling off and on various settings (dns relay, ipv6 locallink)

-enabling or disabling secrity mode

-turning on and off ssid broadcast

-toggling between 20/40 and 20mhz channel width

I know that its specific to my N900 central as my macbooks had no issues connecting before the firmware upgrade and right now I’m connected to my neighbors router as I can’t connect to mine for more than a few seconds.

Can someone please send me a link to the previous version of the firmware, I’d like to roll back to a working version of it as the current one is wreaking havoc on my ability to work remotely.  

Thanks in advance

Have you tried resetting both devices.

Regarding the rollback, I’m not sure if you can force the installation of a previous firmware on a router. Personally, might be or might not be possible


Currently, which firmware are you using?

I’ve reset all devices and am now working on completely starting over given that the router seems to have a mind of its own.  

I’ve obtained a copy of the previous firmware and plan to work on rolling it back.  

Thanks for all your help.


Can you please help me also with a copy of the old firmware?

Pretty pleeeease…I am having this problem since long time and I sick and tired of searching and not finding the old firmware version which worked perfectly…