Why my MBL speed can not reach Gigabit

My route is Netgear  wndr 3700,It is Gigabit route.

I have already use CAT6 network cable.

But when I copy file from MBL to my pc,The transmission speed only 11M and MBL flashing yellow light.

How can I do next ?Need use  CAT7 network cable?

 Need use  CAT7 network cable?

Of course not.   The cable type has absolutely nothing to do with the speed of the connection as long as the cable meets the MINIMUM required, which, for Gigabit Ethernet, is Cat5e.  

If you’re only getting 11M, it sounds like your PC connection is only 100 megabit ethernet, not Gigabit ethernet.

when I connect  PC ->Router->pc ,the speed can reach 60M/s,This mean Gigabit.

When I connect PC->My book live ,the speed can reach 21M/s,This mean Gigabit.

But when I connect  PC ->Router->My book live,the speed only 11M/s,This mean megabit.

So next what can I do?

I would recommend you check the cables, particularly the one with the MBL and make sure they’re not flawed.

Try different cables.

Even your number for PC->My Book Live seems slow (21M)?

But the fact that it drops to 11 when connected to your router also indicates a problem for your router.  The speed should not drop at all.

Mine is PC-> Switch -> Switch - > MBL.  And I get 68 MB/sec.

You can check on both your PC and your MBL for errors in the network.

On your PC enter the command

netstat -es

and look for high Errors, and TCP Segments Retransmitted.

On the MBL via SSH you can enter the command

ifconfig eth0

netstat -s

and look for the same things.

I get similar results as the OP. Netstat shows no errors on either MBL or Macbook pro. Changed cat6 cables and that does not improved anything.

Hi Tony ,

I had change my  cable with amp CAT6 cable.But it is still no used.

I had check the netstat ,it is ok .

I think it is not compatible MBL and Netgear wndr3700.

update the NIC drivers?  That worked for Tony as well IIRC