Why is it so difficult to RMA this device


#1

I have been trying to set up an advanced RMA for the past week for the PR4100. My PR4100 is having a multitude of issues, not limited to some potential electrical issues.

Per supports suggestion, I tried to do the RMA through the support portal, error. I tried about 4 different browsers, including IE11, and I keep getting errors stating that I should try again later. Called again over the phone and I keep getting the run around that the support agents can’t do anything and that they’d escalate it to the department that handles RMA. It’s been over a week now and I can’t get this advanced RMA done. It’s ridiculous!

What other options do I have short of attempting to sell this NAS and getting a NAS from a different provider?


#2

Hello, Scruffy90

Well, try to recreate the A-RMA from your end, In order to create the RMA please redirect to the given link:-

If you fail to create the RMA then you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


#3

I did do both and WD is refusing to give me an ARMA despite the Level 2 techs suggestion.