Where do I start? Help! MyBook Live


About a week ago I purchased a iMac 27" 2.9 from Best Buy.  Up until know I have been using an Apple Powerbook 1.5 running Mac OSX 10.5.8 with a My Book Live that’s a couple years old.  Everything was going OK until I brought the new computer into the house and tried to bring up iphoto using the MBL.  Up until this point It has been working great.  I hold down the option key, select iphoto and boom I have access to 10,000 stored photos.  But when I tried this on my new machine it took a while to load and once it did all I got was empty white boxes that when you clicked on them showed a exclamation point inside of a triangle.  I called geeksquad and that’s when everything went downhill.  The first person I spoke with spent about 60 minutes on remote access and then just gave up and didn’t call me back.  The second person I talked with said it was easy and that I needed to #1 Repair Permissions #2 Rebuild Thumbnails and #3 Repair Database.  So I gave it a try and when I did I found that nothing had changed except that know when I try to pull up photos using my old machine the iphoto file is now gone and I have two other folders that say My Book Live Photo Recovered Photos and MyBook Live Recovered Photos_2.  In the second folder I found only 2,100 of my 10,000 photos that I had before.  I have since called them back and can get no more help.  PLEASE HELP!!  I would be very grateful.  P.S…  I know the photos are still there because when I access MBL using my ipad it says I have 10,000+ photos.

well, first thing is first… Backup your data!!! Backup means you have 2 or more copies of the same files at different devices.

Then you can play around to get the second machine to work.

That would be my recommendation.

Yes I realize that and have made a big mistake there.  I just noticed this morning that all of the files that seem to be missing are the ones on the ipad app labeled under a folder called MyBook Live photo and reads 10,000 files when you pull up the same folder on both computers the same folder reads 0 files…  ??  Thanks for your help