When your controller dies


I have been reading all over this community for a few days now, and I’ve found many different ideas and explanations, tried many things, and so on. First I’ll ask my question, then tell what I experienced, proceed to explain the process I used to discern what I hypothesize to be the problem, and conclude with an explanation of a few ways that I’ve tried to solve it.

With a 2TB MyBook Essential, if the RAID controller ceases to function, is there any way to return the drive to a functioning state without losing any data? I would appreciate ideas besides “go to recovery specialists”, but would also appreciate knowing if that is my only option, or if even that will not work (which sometimes sounds like the verdict).

Please take note that I am on a laptop (Dell Inspiron 15), but can get access to a desktop if necessary. Also, I have never put any passwords on any of my drives.

The drive has served me well for nearly two years. Last week I plugged it into my desktop computer, on which I have used the drive, though not exclusively, since the beginning. Windows XP Pro reported “USB Device Not Recognized”, with it’s little message about malfunction and so on. I tried every other USB port (six in total), and none functioned. I replaced the USB cable and tried again, and it worked fine. I continued to use the drive for several days. Two days ago, I plugged the drive into my new Dell Inspiron 15, and it worked fine. I transferred some files, and shut down my laptop. Shortly thereafter I powered up the laptop again, only to have Windows 7 Home Edition report that “USB Device Not Recognized”. I tried every USB port (three in total), switched out the cable, tried the three again, switched out the cable for a third, and tried every port again. I tried doing the complete powerdown of the drive (disconnect from everything), restarted the laptop, and so on. I also tried the drive on a MacBook and a television (with USB inputs), both of which I have used the drive with in the past. Neither would recognize it’s presence.

I heard no unusual clicking or strange noises from the drive; it seems to power up and spin just fine, which reduced my fears of physical drive failure. I decided to disassemble it and try a little test. I removed the RAID controller from the drive, and attached it to another drive (a Mushkin solid state HDD), and recieved the same results under the same tests (multiple ports, multiple cables, multiple devices). So I went out and bought a new 1TB MyBook Essential USB 3.0. I plugged it in first to make certain that it was fully functional, and it was. I then proceeded to disassemble it. First, I took the old RAID controller and attached it to the new 1TB HDD, which produced the same “USB Device Not Recognized” message, further reinforcing my hypothesis that the old Raid controller is the issue. I then took the new RAID controller and attached it to the old 2TB HDD. It installed fine, and said that the device was ready to be used. I went to My Computer and found no sign of the drive. Then opened SmartWare, and found that it recognized the presence of a drive, but that it had failed to unlock five times in a row, and suggested that I format it. When I declined, it simply showed the drive as being “locked”. I then tried the new RAID controller with the Mushkin solid state HDD, which produced the same results.

From what I’ve read, it sounds like MyBook Essential drives automatically encrypt all data, and that the encryption must match the cypher in the RAID controller; and for this reason no data is recoverable. Is this true?

Again, remember that I am unwilling to do anything which would destroy the data on the drive. Of course, the smart thing would have been to have had redundancy. Now that I have a new unnecessary 1TB drive, I can do just that… But not if there’s nothing to back up. :slight_smile:

I hope that my post has been sufficiently descriptive, and that my thesis question summarizes all sufficiently. I would very much appreciate any insight you can provide. I am also happy to provide more information, should it be necessary for a more adept assessment.



I don’t know where you got the idea that My Book essentials is RAID it’s a single HD. Any external with Smartware  is hardware encrypted by the board with the USB port. Depending on the problem with the board a professional data recovery service may possibly rebuild the board depending on the problem. Probably the only person here with a real understanding of these boards is fzabkar. Read some of his posts or PM him.


1 Like