Whats the best way to play MKV?

Hi. I got a WDTV live media player for xmas just to play all my MKV files I have, until I discovered that I can’t when they didn’t play. After some research I found that I need to remux them with no compression with MKVmerge. They all play fine now but I was wondering, is their an easier way of going about playing MKV files? Using MKVmerge is kind of annoying because you can only do one file at a time or it remuxes it as 1 huge file. Any ideas?

Without compression? What are you talking about?

Hey thanks for replying. Yes without compression. According to my experience it won’t play unless their is none compression. I’d like to use something other than mkvmerge because it [deleted] remuxing one file at a time. Id like to remux multiple files. From what i researched you have to remux with no compression or it won’t play. Is their an easier way that doesnt require remuxing or a better way than mkvmerge?

MKV is just a container format–no content.  So, compression of what tracks in the container?  What type of compression??  zlib compression of subs is supported for MKVs, but probably not for any other tracks.  Generally compression of (already compressed) video and audio formats doesn’t produce any actual compression, so why do it?  What software produced MKVs with compressed A/V tracks??

mkvmerge has a command-line version, which can be used in scripts to process multiple files.  I used it to fix all my bluray subs at one point.  Just start it and walk away.  Does require some programming (scripting) knowledge, however:


1 Like

Are you talking about “Header Compression?” If so, that hasn’t been an issue in years.

Hey Ncarver. I read I have to remux the mkv’s Audio and Video track with no compression if I want to play an mkv file on the WDTV, is that right? When I tried to simply copy the mkv onto a flash drive and play it on the WDTV it wouldn’t work. So I assumed I have to remux all mkvs with no compression on the A/V track because when I do that it works.Are you saying that not all mkvs have compressed audio/video so I don’t need to use MKVmerge all the time? I have no experience with scripting either so I guess I’m screwed remuxing multiple files using mkvmerge. Its lame I can’t simply copy my mkv files to my flash drive plug it into the WDTV and play it. Everytime I have to use MKVmerge with every mkv I want to play on it :cry: Is their a better program that remuxes multiple mkvs with the no compression option? Whats the easiest way to get mkvs to play on the WDTV?

Yes I’m talking about header compression. Really? No issues playing Mkv? Maybe the files I tried had compressed A/V tracks and I didn’t know it because it would’nt play it. I’ll go run some tests with different MKV files and see if that works. Thanks Tony.

Here is what the mkvmerge GUI page says:

“Compression: Matroska features a powerful system for compressing tracks with lossless compression algorithms. Those compressions can be applied to any given track, but some players only support this for VobSub tracks. This is where it’s most useful. Other tracks, especially audio and video tracks, are already compressed so that additional compression will not yield any result. For VobSubs you can achieve an additional gain of about 30% if you enable zlib compression. That’s why it is the default for VobSub tracks.
You should just leave this setting at default.”

The mkvmerge CLI page says:

Example: Turn off the compression for an input file.

$ mkvmerge -o no-compression.mkv --compression -1:none MyMovie.avi --compression -1:none mymovie.srt

So I just tested some other mkv files by just simply copy and pasting them to my flash drive and it worked. Sorry, I’m a noob. Maybe the first one didn’t play because it was an old MKV? I don’t know but thanks for the help everyone. Happy Holidays.

You said your using a flash drive, What file sizes are your Mkvs Someone correct me if Im wrong but wasnt there a 2gb file limit on video for flash drives. Ive never had any problems with Mkvs on a 2TB Hard drive, except where the convertion has been badly done. Have you tried using a hard drive or streaming the file that does not work.

The file size limitation is not based on the hard disk technology, though it can be an issue of how it’s formatted.

NTFS – no limitations.

FAT / FAT32 - 4GB maximum file size

Oh Ok Cheers. I never really play anything through a flash drive always use an external USB or streaming.