What's my problem?

I have a 6 month old 3TB My Book Live that contains only 539 movies (approx. 2.7 TB) in MKV format.  It has firmware  I use it only to stream movies to my Samsung TV’s.  Up to now, it has worked as promised when I switched from the Twonky media server to the WDdlna server.

A problem has popped up when I uploaded 3 movies in MKV format (The Croods, Grown Ups 2, and The Heat).  When I try to stream The Croods and The Heat, I get a message on my tv that says the file is not supported.  However, Grown Ups 2 does stream with no problem.

I rescanned and rebuilt the database thinking there was corruption…it did not fix the problem.  I then re-encoded The Heat and uploaded again.  Still the same problem.  I then rescanned and rebuilt the database and I still have the problem.

I have used the same software settings when I converted my movies so I doubt this is the problem.  One issue I noticed when I rebuilt the database the first time, the dashboard reported 539 movies but on the tv screen it said 299.  After rebuilding the second time all the numbers matched.

Can somebody give my any ideas to what the problem is?

there is something different between your three test files. perhaps size is the issue.

Can you play the files by accesing them with Samba (windows explorer)? 

Can you play the files when they are streamed to Windows Media Player?

Can you play all the files with DLNA server streaming?

What version of Twonky are you using?  Have you ever attempted to update it?

Lot of things you can think through to rule out possible causes.