What's gone wrong with my MBL, MyCloud etc?

I very recently moved house and changed internet provider from Virgin to TalkTalk (I had little choice!). I was looking forward to putting my MBL back online as I need access to my archive of photos and artwork.

  1. I have tried but cannot access the MBL (via wifi, or via direct cable to the wifi router, nor via ethernet cable direct between my MacBook Pro and the MBL.
    The WD My Cloud app on the MBP says that it detects the device, but it cannot connect. Likewise what few other tools I just about understand enough to use also detect it (MacOS 10.13.6 - Network shows the ‘thundernet’ cable as ‘connected’), but do not allow any access. The light at the front of the MBL is steady green, the lights at the back show green and flashing green. I have tried mybook.local etc in vain (cannot connect… server not responding)
  2. I cannot see the Control Panel anymore and I don’t have enough understanding to confidently (or safely) put into practice the suggestions made in threads elsewhere. If any one is kind enough to respond to this, please bear this in mind - I’m not inexperienced but have little knowledge of protocols.
  3. On my iPhone (SE iOS 13.3) the MyCloud app has changed and cannot either see the MBL or, more alarming yet, my online MyCloud backup! This came as a real shock to me. I’d not heard anything about changing this service, just as I’d not heard anything about ending support for the MBL line - despite registering the product so I’d receive updates.
  4. Likewise, I seem prevented from accessing the MyCloud service online via any browser from my MacBook Pro, iPhone or iPad.
  5. I bought myself a WD Passport in the sales and was looking forward to using it to download my photo trips but now I’m in doubt - what happens when WD make that obsolescent?

I have some but not all also copied to cloud services on the interweb (Google, Amazon) but not all, and I have no way of recalling what is stored where and certainly much is kept only on the MBL.