What is upnp_nas_device and why is it running nonstop? All lights on

This morning all three lights on MCM were on. That’s not right it should be asleep. I open the dashboard and see memory at 40% and process at 50%.

I have all of the media streaming, itunes, time machine, cloud features turned off.

The biggest thing under process is upnp_nas_device at 14%
I also have 6 instances of httpd at 8.5%

Why is upnp_nas_device running and how do I kill it?

update
Six instances of httpd running and six shares can’t be a coincidence. I created a 7th share and rechecked process, now there are 7 instances of httpd running. Does this need to be running for each share? I don’t use HTTP download nor have I ever tried it.

The 2 drive lights were on this morning but the drives were not spinning. The top light was blinking slowly which used to indicate sleep.

Found a similar thread about mediacrawler running non stop on MB Live a few years ago.

I may try the technique of making the file upnp_nas_device unexecutable by changing the permissions.

Here’s the older thread:

I SSHed into the box found the PID of upnp_nas_device and KILLed it. Everything seemed to work ok with one exception:

In Windows 10 the MCM shows up in Windows Explorer under network twice; once as a computer and and once under storage. Oddly the one under computer gets you to the shares and the one under storage launches the dashboard. With upnp_nas_device not running MCM doesn’t show up under storage. I could still launch the dashboard by typing the IP address into a browser and could still get to the shares.

This morning MCM had both drive lights on solid and the power light was blinking slowly. The drives did not seem to be spinning. It seems the latest firmware changed the blink rate of the power light so it doesn’t fade in and out as rapidly as it used too.

The drive lights being on solid when they are not running makes no sense to me. It should be the way it used to be when MCM is sleeping:
Power light slow blink
Drive lights out

Hello,

As a recommendation, try contacting WD Support for direct assistance.

WD Contact info: http://support.wdc.com/contact.aspx?lang=en

Just curious. Was that a serious suggestion?