What is causing the permission denied error (red dash) on my share folders in macOS

this is a persistent problem i have over some time now and i determined its very unlikely caused due to something in macOS.

I mount my shares as SMB on my mac, and a brief time after, the folders within all the shares i mount now display a red dash in the top left corner. error message is i do not have permission to access.

i’ve checked my keychains and tried deleting/recreating keychains when trying to connect to the shares again. always have the same problem.

when i use AFP, i never have an issue. same credentials used to access the shares as with SMB.

so this has to be some authentication problem on the NAS and how it implements users.

can i please get some help with this issue I’d like to finally resolve it and stop using AFP.

anyone have suggestions ?

I am sorry, I do not have an answer. However I am on Windows and my mapped Netwrok Drive now since the OS 5 update constatntly comes up with the no permission or password incorrect and does not link.
I have to disconnect the drive mapping and rebuild it, then it is OK till I restart my PC.

no apology needed. looks like you have issues as well but with windows usage instead of mac.

i’ve seen wd staff here censor my posts, mostly because they dont want to see posts highlighting this type of problem.

inherent to these devices probably. and i regret picking up this ex2 a few years ago, my issue has been around for at least 3 mac OS major releases, so its at least 3 years old problem now.

i am trying to use NFS rather than SMB because of that.

i’ve already turned away from wd hdd’s since i had a failure recently. going to start looking at qnap for a new NAS enclosure.

i don’t recommend WD, they just don’t work well and to top everything off, the staff on this forum censors my questions.

i ‘fixed’ the issue …

but the way i fixed it left me wondering what the meaning of a “Private” share is … ?

in the dashboard, i made all of my Private shares into Public (toggling the Public switch on each one).
SMB works normally now, so i also think that NFS would work without permission errors either.

to WD: what is the purpose of a “Private” share, if it cannot be used with SMB or NFS on a mac ? WD doesn’t support AFP either – which is the only protocol people would be able to use with “Private” shares …

I’m on Windows but I had much the same issue as you once the 5.13.115 firmware was loaded. Seems now you cannot use the web Admin (even if renamed) account as a user account with this update. I had most of my data on a shared USB so I still had access to my data after removal. Once I created a user only account and used that to set permission all worked as expected.



it looks like there is some issue with the latest ex2 firmware. using the admin’s credentials should work for all the shares that the admin was given access to in the dashboard. the switches in the dashboard are confusing and negate each other because you have the ability in the shares pane to control user access, and also have the ability in the users pane to control share access.

my issue specifically, did not occur in windows or on the latest firmware, it’s been chronic in mac OS and for some time now (a few years worth of updates on both mac OS and the EX2 firmwares). ironically, i don’t have the issue in windows.