What are valid FTP ports for MCM

My router, netgear R7000, has port 21 reserved for it’s USB port. I need to use a different port to set up FTP on the MCM. I tried 8021 but couldn’t get it to work. Does the MCM have specific port numbers that will work with FTP?

Hi there,

Normally on older software, you could use port 666, however i don’t know if this is the same now days, lets see if another user can share some information or tips on this matter.

I checked the manual and it is not much help. Nothing about valid ports but I’ve seen for other products it needs to be; 9921, 8021, etc.

I’ve tried port forwarding 8021 external to 8021 internal, 8021 to 21, share public, share private, deleted user and share then readded.

So many different things I’ve lost track of what I’ve tried.

Now works!

Not exactly sure why it now works but it does. Maybe it was the order in which I did things and rebooting the router and MCM.

I have two sets of ports forwarded on the router
8021 both external and internal
55536-55663 both external and internal
I couldn’t call them FTP since that name is reserved but the name doesn’t seem to matter.

On the MCM
Turned on the FTP service under Settings-Network
Port 8021
Passive Mode checked report external IP in PASV mode
My modem IP address is there
Under customize I have 55536-55663
Left everything else alone

Created new user with password
went to share that was created for that user and turned on FTP
Left Anonymous at None
Left access Public

I can get to it from outside using Chrome ftp://user:password@
Can also get to it from Android using ES File Explorer
Opens in Windows Explorer without asking for a login from a PC on the same network as MCM.

One thing I noticed was if you are using a ‘Test My FTP’ site the MCM will eventually block that site. You get no notice of it happening and the only place I saw it was on the last page of configure FTP under Setting-Network. Probably added it after multiple login attempts failed. You can clear it out on that last page. There should be some kind of notice that a site was blocked especially if you have Notifications enabled and set to all like I do.

*** update ***
All my troubles were most likely due to my router. I had port forwarding set up to MCM port 8021 for a while but hadn’t used it. About two weeks ago I had updated my router firmware. Just had a problem with another service that required port forwarding and it wouldn’t work. Went into router deleted the entries and readded them; everything now works. I have no choice but to assume the Netgear firmware update hosed my forwarded ports. Thankfully my DHCP reservations seem to be working.