What am I doing wrong?

Since Factory restoring, have lost access using WD2GO on mobile devices.


Have set up the MBL with a Static IP Address, see shot:

Connects ok to the router, but the MBL shows the following:


Dont know why it says NO INTERNET ACCESS

Anyway, the other screens:

The router:

And the MBL:


What am I doing wrong? Please!!!



The screen shot does not show the Gateway and DNS server

if the values for those are incorrect it will not connect 

Are you getting the information from the router or ip’s config? 

Another suggestion may be to use a different external port other than 80 and 443. You may have other devices on your network that using these ports.

If you did a factory restore, you may have to generate a new DAC code to connect up WD2go for mobile devices.

WD Tony, when you say a different Port, where abouts do I do that?

My Internet Connection is good, just the Port Forwarding is not working.  Have attached latest screen shots after it is fixed.

Thanks for your help!


I am about to pull all my hair out.

When I first got it, all worked ok. Using DHCP I could use WD2GO and it worked fine with my PS3.

AFter a factory restore, I checked for latest patches, all up to date.

But now wih DHCP it is NOT WORKING and the PS3 will not recognise anythin under the Public area…

What can I do??

You should try to get it back to a known state before attempting to forward ports again. Try pushing the reset button on the back of the box. That will reset the DHCP settings and reset the owner password. If that fails, try unplugging and plugging the box back in.

Once you got it all back to working normally, you can define any port you want to open up as the external port. For example, I chose ports 5501 and 5500 as my external ports (sort of random). You then set these external ports to forward to ports 80 and 443 on the internal IP address that you assign to the MBL. There is a pretty extensive FAQ up on our website that shows you how to do this. Sounds like you are almost there.


OK - I hit the reset button.

I know this worked as I did not need a password.

This is what I did from there:

  1. Static IP - got the MAC address from the MBL, and went to my Router. Set it up as a Statis IP address.

2 Went into the MBL Dashboard and set it to Static, and entered the IP address assigned above.

  1. Rebooted the MBL - it now has taken on the Satic IP address. See below from the MBL:


So, Internet Access = Good, and static IP address.

  1. Went into the MBL Remote Access setup, and Remote Access Ticked, Connection Status - FAILED.

  2. Changed Connection options to Manual, used 5500 and 5501 (similar to you). See below:


  1. Went into Router, and set up port forwarding. See below:

  1. Rebooted both MBL and Router, checked that all settings were as expected.

Now, this is STILL failing on rthe Connection under Remote Access.

Have I got the External / Redirect Ports the correct way in the Router Settings?  I have now tried everything and dont know what to do.



That all looks correct to me. The only thing I can think of is to add a known DNS server to the list. Add Google’s servers to your list of DNS servers.

Other things you can do are to reboot the Duo and disable/Enable Remote Access.

Google’s DNS are:

Relying on your Router for DNS is not a good idea.

OK, I have added the and and kept the router one.

Still says FAILED.

Have I got the 5500 / 80 and 5501 / 443 in the right spots in the router?

Thanks heaps for all your help… it is starting to worry me as normally I am good with this stuff!!!

Can you check on the router to see if there is actual trafic coming, but not getting forwarded??

Just noticed in the first picture that you’re setting a Static ARP address?  Why?  That is NOT the same thing as a Static IP address.

You should not have to do that.

Hey, that is a stupid error on my behalf.

I have removed ALL references to IP assigning under the static ARP area etc and have restarted.

I then performed a Firmware upgrade on my Router (Billion 7404VGPX).

Then, reset (again) the MBL, so all NW and Password settings removed.

  1. Setup Static IP (in proper location!) on the router

  2. Setup Static IP under Network Tab in MBL.

Checked that it has been assigned, and that the Internet Connection under the Network Tab in MBL as Good. So far all good.

  1. Then went into router, and setup Port Forwarding. I used 80 / 443 and 80 / 443 initially.

  2. Rebooted both router and MBL (necessary?? no sure) and still said FAILED under Remote Access

  3. Changed the settings to 8080 / 8443 and 80 / 443 on the Router, 8080 / 8443 on the MBL

  4. Rebooted both router and MBL (necessary?? no sure) and still said FAILED under Remote Access

  5. Then reversed the settings in the router, in case I got them the wrong way around.

  6. Rebooted both router and MBL (necessary?? no sure) and still said FAILED under Remote Access

I have tried everything and have had a heap of help from you all - THANKS.

Shame it is now not doing what I bought it for - I need it to stream to iPad etc.

I will have to contact retailer to see if I can return it… not sure  :(

Thanks again everyone.

The 7404VGPX supports UPnP. 

Why not just enable that, and use AUTO on the MBL?

What do I need to do for this?  I have alse read that WMM needs to be enabled on the Wireless option under the router?

I checked Device Management and the UPnP is on, port 2800.  I deleted all Port Forwarding stuff on Router, and set the Port Fwd on the MBL to AUTO.

Restarted both, still says FAILED under the Remote Access area. On the PS3 I am getting a DNLA (2006) error also. 

The Internet Connection under Network is still GOOD though.

I am at a loss in what I can do. Am sorry about this and very grateful for everyones help

My only suggestion at this point would be to see if you can cart your MBL over to a friend / neighbor’s house (that might have a different brand of router) and see if it works there…

Doing a quick google, it’s not hard to find people that are having problems with that Make / Model of router you have, but who knows…

Thanks all for your help - I heard another thing about ISPs blocking this stuff, so went into ISP Toolbox and Port Blocking was enabled, posts blocked included 80 Inbound and 443 inbound

So, I turned this off, waited and still no success.

One thing is now the Dashboard does not work from the Quick View, but I CAN get to it via IP Address.

Anyway, will take to mates and try.

Thanks again everyone.