Western Digital My Book Essential 2TB USB2.0

I removed a Western Digital My Book Essential 2TB USB2.0 drive from inside the enclosure and now the data doesnt show up on my Windows 7 64 bit bare or with the enclosure. It simply promts me to reformat before I can use it. I must retrieve the data from the drive, so what is the software I would need to retrieve that? I have a lot of time invested, and formatting the drive to reuse it simply isn’t an option.

I noticed the sticky with the “data recovery partners” link, but I’m looking for software to scan the drive and recover the data. The dive itself per s.m.a.r.t. is in great condition. I’ve tried a few weeks ago, but they didn’t work.


Update: I am able to mount the disk in Windows 7 64 bit and assign it a drive letter. When I try to access it, Windows tells me that I must format the device before I can use it. I have the option of both NTFS and FAT. I do not know what format it was originally in (99% was NTFS), so I did not format it. I have tried both NTFS file system recovery and FAT system recovery from www. runtime.org/ “Getdataback” but the software won’t detect either FAT or NTFS structures on the disk to recover. Should I format this drive in NTFS or FAT before I try to recover it? Are WD external drives in some previously unknown format that is impossible to recover?

Well the circuit board with the USB port supplies hardware encryption. Even if you get data off the drive without that board it will be encrypted and useless. Don’t format the drive if you want to recover data. Why did you take the drive out of the enclosure?


1 Like


I had to take My Book 2tb external out of my case as well.

The usb header broke off the circut board in the external enclosure.

Is the usb cicuit board needed to read /write to the drive for decrypting /re-encrypting the the drive at a hardware level after its reformatted?

I am having trouble where the drive it starts to create partitions. But will not install win7 on the new partition it just hangs.

I have also tried repartioning it in gparted in ubuntu it sits on partitioning it forever.

So im thinking that board maybe required reguardless of  reformatting it or not. Does that make sense?

I was going to resoder the header back on the circuit board and try formatting that way.

Let me know what you think?


The board with USB does handle the encryption/decryption. I don’t know about reformatting it without the board. I think you may need to write zeroes to it first. Send ThePizzaMatrix a PM he can probably help you more.


Sent him a message posted it here incase others might have the same questions.

The question is for my MyBook 2TB drive now that I formatted it on Sata without the usb board will I need it to always read/write to it.

Since I am having trouble having the drive being seen correctly in OSX, WIN7 or Ubuntu. However in Ubuntu. All The OS’s start the format but never finish. I have re-writen the partition table under linux once as fat32 when it told me the drive had no partition table.

So I need to resoder the micro usb connector and use that if this is the case haaa. Yeah trying to save money and not have to buy a new drive.

Let me know if I should just try writing zeros and see if that squares it away? I am not sure if that board is required by a chip on the hard drive looking for it  for all reading and writing even if it was reformatted. That would make sense since the drive I know is not bad its almost brand new so its not a platter issue.