Western Digital Elements 1TB USB 2.0 Desktop External Hard Drive Disk Error


#1

When plugging my Western Digital Elements 1TB USB 2.0 Desktop External Hard Drive WDBAAU0010HBK-NESN into my computer it loads the needed drives (i have installed and used this before, it has stuff on it from the same computer). When I go to open the external, it asks me to insert a disk into the removable disk.  I am unable to open the external, access any of my files or to transfer anymore onto it. Help? Thanks.


#2

Hi

If I understand right, when you try to click on the drive with My Computer, at that point, Windows asks you to - what? insert a disk in the removable disk drive? Can you be a bit more specific with exactly what is happening? It might sound pedantic but it does help, really.

Regards,

Dave

P.S. The other thing to try is to attach the external unit to another PC, in case the problem is something to do with that particular PC.


#3

There is nothing else that happens, and the same thing happens for every PC i hook it up to.

Here is a screen shot:


#4

I should also add that nothing happens after this…


#5

Have you tried reformatting?  Could be a corrupted partition.  I would try that, unless you have data on the drive that isn’t elsewhere, then you may want to look into data recovery.


#6

I attempted to reformat the drive, it gave me an error saying that there was no drive available.

my harddrive is still under warranty… i can live without the data as long as the 100$ for this doesn’t go to waste, would it be covered?


#7

Did you look in Disk Management to see if the drive was there?

  1. Right-click Computer
  2. Left-click Manage
  3. Left-click Disk Manage

You should see the drive in the bottom window on the right.


#8

Disk 1, Drive E is where my external harddrive is plugged into… as you can see it is very not there.  What does this mean and/or how can I fix it?


#9

Drive “E” is a removable disk that now uses the drive letter that your Elements drive used to use.  Does your Elements drive still show up under the “Disk Drives” category within Device Manager?  What happens if you connect your drive to another computer?


#10

Heres what happened:


#11

also, other computers don’t read the harddrive at all


#12

Windows is having problems recognizing the hardware of your drive so does your drive work properly when it is the only USB device connected to the computer?  Otherwise, have you tried updated the computer’s BIOS to the latest release and/or resetting the BIOS back to the defaults?

If not, are you hooking up your external hard drive to a USB hub or extension cable?  It is always recommend that you plug your external hard drive directly into your computer.  Furthermore, does the power adapter you connect to your drive match the one from the link below?  WD only recommends using the factory-supplied power adapter.

http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=1378&p_created=1118358612

Do you plug your external hard drive’s A/C adapter into a power strip or directly into a wall socket?  If you are using a power strip or battery backup then we recommend that you connect your hard drive directly into a wall socket.  In the past, we have seen several customers who have had issues using power strips and battery backup devices.

Have you installed the latest OS updates as well as updated the USB controller drivers on your computer?  Have you tried connecting your external hard drive’s USB cable into a different USB port on your computer?  When connected to a different port, do you have the same problem?  Have you tried a different USB cable?  Are you experiencing any other problems with USB devices on your computer? 


#13

The hardware of my drive is unrecognized regardless if it is the only thing plugged in or not.  Yes it is directly plugged into the computer and directly plugged into the wall socket.  I am using the usb and ac adapter it came with.  The BIOS have not changed since I got the harddrive and it worked for a good two weeks prior.  The OS has been updated and so has the USB drivers.  The drive does not work in any other USB drives and additionally there are no other USB problems with my computer. 


#14

If no computer recognizes the drive even after changing the USB cable, you have a failed drive.  In that case, please see the link below for replacement information.

How to request an RMA (Return Merchandise Authorization) or replace a defective product under warranty


#15

I Had the same thing happen to  me but i don’t know how it fixed itself but now its working seem it may be a kink that developes after long term the Western Digital Team may want to start troubleshooting nothing like the FEAR of losing all you pics videos movies and software programs… I just both me a 16 gig flash stick to back up all pics music and videos and software just in case…