Weird WD Live Hub Networking issue

Hopefully you guys can help me figure this one out.  I am currently running my WD live Hub through a powerline adapter into my wireless router.  All was working fine till I completed all the new firmware updates.  Now whenever I attempt to move data from my desktop PC to my Live hub it will create the following error message “file path too long”  Then the network drops to WD live hub.  BUT I am able to move files from from my live hub back to my desktop.  Please help this has been driving me nuts for about a week


Does this help?

Thanks for the response but that did not help.  My system is running XP.  I think it has something to do with the new firmware that I updated my WD live hub with.  I had to keep recreating the path to the drive.  Is there someway to remap the drive to shorten the fila path down?  I have been unable to find a way to do this

If that’s the case, then a rollback to the previous version would fix the problem. Have you tried that?

Just wondering if the powerline adapters could somehow be involved in this…have you tried just connecting the Hub directly to the router with a cat5 cable?