We media player won't read wed my cloud files

Hi. I have the latest wd media player and a wd mycloud. They connect ok I also have a sony smart blueray player that reads the drive on the network. My problem is, nothing players say " no readable media content " when there is loads. What settings do I need the play with. My PCs and iPad stream content fine.

Stream them via pc with cast now should solve your issues also make sure you have latest software of my cloud wd.com/mycloud


I don’t use the cloud, but as for the “cast” method (correct me if I’m wrong), you’re not seeing the files (media library) on the WDTV itself. Am I right? If so, it is far from convenient and so I hope a ‘cloud’ user can help here!

This is a baloney solution! The OP cannot get media from his My Cloud to play on his WDTV, and he needs a solution for THAT, since 1000s of people can do this, and not told to use some sort of PC program. This is not rocket science. I have this equipment and I can do it!

OK, for the OP: Has this ever worked for you? is your My Cloud sort of brand new and recently set up? The My Cloud is likely not set up correctly, so go to support.wdc.com and download the full user manual for your MC device and go through the setup to see where you have gone wrong. Have you tried accessing the MC from WDTV from BOTH Media server and Network shares? And, neither works?

1 Like