WDTV Live viewing films


no idea what my problems could be so I will try to be as brief as poss.

I have a 1tb drive connected, which I store downloaded films and tv series on. A couple of weeks ago I added a couple of films and some episodes of tv shows. When I tried to view them, on some of the newly added files, I got a message saying that the files were empty, yet others played OK.

I had a 2tb drive available, Seagate, so I copied a few files to that. Result was nothing was viewable.

I updated the firmware to 1.06.43 , no change, but when I tried to roll back the firmware, downloaded to a USB stick, the “update” was not recognised by the player.

No idea what to try/do next…any help/advice would be greatly appreciated.

If you need more info please ask.

Thanks in advance.

Are you adding the movies by moving the drives back and forth from the WDTV and a PC? If so:

Suggest you connect the drive to a windows computer and check the drive for errors. Windows Explorer>properties>tools>Check Now>automatically fix file system errors.

The drive may be flagged as “dirty” and need to have the flag reset by the Error check.  The WD can be picky about this.be sure to “safely remove” the drive by the OS before unplugging.  In windows use either the “Safely remove hardware and eject media” in the applet bar. On the WDTV use the “Eject” button on the remote.


interesting comment, and I am sure you are on the right lines !!!

Frequently over the past 3 months, when I have moved the drive from the WD to my PC to add further files, the PC has picked up a fault on the drive, which initially I could fix with the Windows Error check etc. …    I get the same message about errors on the drive when I connect to the PC now, however, when Windows tries to do the scan/fix , it stops, with the message "Unable to fix the erors " !!!

Q 1. Is there a command to force the scan/fix to complete ?

I did reformat the drive, and only put on a fraction of the files held before, but still have the same problem

Thanks for any help.

From a command prompt (as administrator) CHKDSK x: /R  where x=drive

OK  did that and a small screen flashed up which was too fast to read !!

Went back to Files, Properties etc. and tried to run the “Check” from there.  As before, runs for a few seconds and then a message "Error Checking…Windows was unable to repair this drive "

Stuck now ?

In your wundows/system32 directory right click on cmd.exe and select "Run as administrator?  then in the window that opens type the chkdsk x: /r  command as listed in prior post.

You might want to right click the cmd.exe, copy and the paste as a shortcut to your desktop for future use.


 Found C:/Windows/System32  but cannot see “directory”  ???  Could you point me at it please …this is all new to me  !!!

OK I missed putting a comma after System32.  That is the directory (System32) where you will find “cmd.exe”.


I must be missing something …I cannot see “Cmd.exe” anywhere.If I expand with the  + next to C: Windows/System 32 I get a long list starting with  “0409”  finishing with " connected-search-suggestions " .

Sorry :crying_cat_face:

Further update. I downloaded a disc checking program from Seatools, and ran a full check repair on the HD. No problems discovered on the disc. 5 hour scan!!! . I then used the " Right click on the drive, >properties > tools>check . Message about the disc has errors, please scan and repair, but Windows unable to complete the scan. Re-formatted the disc, and ran same check as above. No problems on the drive …great ! Added files to the HD, 2 which I could play before, and 2 which gave a message about "no media in this file ". Connected to WD player and tried to access the files. Message appears that "No media on this drive ". I then shut down the WD player correctly and reconnected to PC. Files were still there and viewable on the PC screen. Rtclick of drive>properties etc. and check …errors on drive which Windows could not repair . Now completely stuck !!

Hopefully the problem is resolved.

In short, I am sure that it was all caused by failing to use the correct “Eject” procedures when disconnecting the HD from the media player.

I have added files, viewed them ok, disconnected the HD and added further files, and also run chkdsk each time.

No problems reported by chkdsk, and no problems from the HD and media player.

Hope this helps somebody else.

Sorry, probably should have had you go into Windows Explorer>Tools>Folder Options and make sure that:

“Show hidden files, folders and drives” is selected

“Hide extensions for know file types” is un-selected

“Hide protected operating system files” is un-selected

Then “cmd.exe” should have been visible to you in the long list.

Anyway glad you problem has been resolved.  USB drives really do need to be safely disconnected to prevent file system corruption.

Thanks for that info…I didn’t realize that some of the files were hidden. My last OS was XP, and I had it set up to see all files etc. I have now made that adjustment with the new OS. Thanks again Braumeister